Bug 202292 - Eclipse crashes on startup
Eclipse crashes on startup
Status: CLOSED DUPLICATE of bug 201778
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-12 04:51 EDT by Mauri Korkeala
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-12 09:30:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mauri Korkeala 2006-08-12 04:51:29 EDT
Description of problem:
When starting eclipse from terminal or gnome meny, Fedora Eclipse splash screen
is displayed, eclipse starts loading and then JVM crashes.

Version-Release number of selected component (if applicable):
java-1.4.2-gcj-compat-1.4.2.0-40jpp_100rh
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_100rh
gcc-4.1.1-14
gcc-java-4.1.1-14
libgcj-4.1.
libgcj-devel-4.1.1-141-14
eclipse-rcp-3.2.0-1jpp_11fc
eclipse-jdt-3.2.0-1jpp_11fc
eclipse-ecj-3.2.0-1jpp_11fc
eclipse-platform-3.2.0-1jpp_11fc


How reproducible:
Always

Steps to Reproduce:
1. Install eclipse vie yum
2. Start eclipse
3. Watch it crash
  
Actual results:
JVM terminated. Exit code=127
/usr/bin/java -jar startup.jar -os linux -ws gtk -arch x86 -launcher
/usr/bin/eclipse -name Eclipse -showsplash 600 -exitdata a000e -vm /usr/bin/java
-vm args -jar startup.jar

Error printed on terminal (probably the cause):
/usr/bin/java: symbol lookup error:
/usr/share/eclipse/configuration/org.eclipse.osgi/bundles/36/1/.cp/libswt-mozilla-gtk-3232.so:
undefined symbol: NS_InitEmbedding

Expected results:
Eclipse is started.

Additional info:
FC6 test2 fully updated. SELinux disabled. No software installed outside core
and extras (development) repos.
Comment 1 Ben Konrath 2006-08-12 09:30:59 EDT

*** This bug has been marked as a duplicate of 201778 ***

Note You need to log in before you can comment on or make changes to this bug.