Bug 202296 - X doens't resume from suspend to ram (Radeon 9600 M10)
X doens't resume from suspend to ram (Radeon 9600 M10)
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: hal-info (Show other bugs)
7
i386 Linux
medium Severity high
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-12 06:21 EDT by Mauri Korkeala
Modified: 2013-03-05 22:46 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-24 23:46:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log (39.54 KB, text/plain)
2006-08-12 06:23 EDT, Mauri Korkeala
no flags Details
/var/log/messages (10.71 KB, application/octet-stream)
2006-08-12 06:25 EDT, Mauri Korkeala
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 7854 None None None Never

  None (edit)
Description Mauri Korkeala 2006-08-12 06:21:44 EDT
Description of problem:
When resuming from suspend state, screen remains blank. Switching to virtual
consoles doesn't help. I can log in blindly when swithing to virtual consele and
perform shutdown. Also I can remotely log in with ssh and the computer is
running otherwise normally. 

Version-Release number of selected component (if applicable):
xorg-x11-drv-ati-6.6.1-8.fc6
xorg-x11-drivers-7.1-2.1

How reproducible:
Always

Steps to Reproduce:
1. Boot and log in
2. Suspend using gnome menu bar System->Suspend
3. Resume when computer is suspended
  
Actual results:
Scree remains blank, session data is lost.

Expected results:
Old session is restored.

Additional info:
Hardware: HP nw8000, Radeon 9600 M10
Suspend to ram was working after updates at some stage when using FC5, but I
can't remember what driver I was using at that time. (Don't know whats the
status at the moment.)

Increased the severity level to high as the Suspend button is such a visible
spot in the menu and it's even possible to accidentaly to click it.
Comment 1 Mauri Korkeala 2006-08-12 06:23:30 EDT
Created attachment 134076 [details]
xorg log
Comment 2 Mauri Korkeala 2006-08-12 06:25:43 EDT
Created attachment 134077 [details]
/var/log/messages
Comment 3 Kevin Fenzi 2007-03-24 00:25:25 EDT
Hey Mauri. Is this still happening with final fc6 and/or development? 

In fc6, does editing /etc/acpi/events/video.conf and commenting in the 

event=video.*
action=/usr/sbin/vbetool dpms on

lines get it working?
Comment 4 Mauri Korkeala 2007-03-26 10:23:09 EDT
Hi, 

It still doesn't work with updated FC6. Still same problem that Screen stays
blank but the machine is otherwise working properly. So the suspend is
completely unusable. The ATIs binary-only driver works with similar hardware.

(Actually with latest kernel I have to blacklist i2c_i801 module or else the
suspend is completely broken. This however should be soon fixed on upstream kernel.)

If there is anythink you want be to try or provide more info, I'll be happy to
help. I'll try updated rawhide as soon as I have time.
Comment 5 Kevin Fenzi 2007-03-26 12:18:16 EDT
Have you had a chance to try the suggestion in comment #3? 
Trying on rawhide would be good too if you can manage... 

Should this bug get moved to fc6 instead of fc6t2?
Comment 6 Mauri Korkeala 2007-03-26 13:44:29 EDT
Sorry, forgot to mention that I also tried with those lines commented in, as
suggested in comment #3.
And you're right, it would make more sense to move this to fc6.

I think I'll try rawhide right now, I'll make a comment here soon how it went.
(Althouh I'm pretty sure the problem persists there too, as last time I tried it
didn't work.)
Comment 7 Mauri Korkeala 2007-03-26 15:37:24 EDT
Yep, also the current rawhide (updated fc7test2) had the same problem.
(The file /etc/acpi/events/video.conf didn't exist in fc7)
Comment 8 Phil Knirsch 2007-05-16 05:38:48 EDT
I see /etc/acpi/events/video.conf on a FC6 and a F7 install.

Despite this not fixing your problem, we can't enable this behaviour by default
as it breaks a lot of other laptops when you do that.

Thats why there is a comment in that file that explains when to enable it.

Your bug here looks more like a xorg driver problem though.

One thing you could try is to switch to a text console before suspending and
suspend from a text console there using the command pm-suspend. If they system
comes back normally then this might give us a clue what to do for this specific
laptop.

Thanks,

Read ya, Phil
Comment 9 Mauri Korkeala 2007-05-18 14:59:16 EDT
Command pm-susmend produced similar results. Screen remained blank but I could
type shutdown -r 0 to console to reboot the machine. I tried that run-levels 3
and 5. 

Anything else I could do to help?

This was indeed working during FC5 this is regression, probably in xorg driver.
Comment 10 Mauri Korkeala 2007-05-18 15:05:23 EDT
Forgot to mention that this was now tested in FC6. Any point testing this also
with FC7 test 4?
Comment 11 Kevin Fenzi 2007-05-18 15:07:24 EDT
Yeah, fc7t4 (or rawhide) would be better... hal there knows about the quirks of
much more laptops. 

Can you also take a look at: 
http://people.freedesktop.org/~hughsient/temp/quirk/quirk-intro.html

and try the various quirks there and see if you can find a combo that works?
Comment 12 Mauri Korkeala 2007-05-22 15:43:46 EDT
Yes, found a quirk (combo) that works (Running rawhide)!  
Command 'pm-suspend --quirk-vbestate-restore' works correctly. With that command
I saw couple times some distorted colours on the screen, which I didn't saw
using combo 'pm-suspend --quirk-vbemode-restore --quirk-vbestate-restore'. But
that might as well be bad luck. Anyway both these work great. 

I will now try to edit that fdi file to make it work using GUI. After that I'll
follow the instructions on the quirks webpage for submitting the solution for
all to benefit. (Email the working config to some mail list?)

Working versions:
kernel-2.6.21-1.3167.fc7
hal-0.5.9-8.fc7
pm-utils-0.99.3-5.fc7
xorg-x11-drv-ati-6.6.3-2.fc7
xorg-x11-server-Xorg-1.3.0.0-5.fc7
Comment 13 Mauri Korkeala 2007-05-22 15:55:35 EDT
Bah, typical, the people.freedesktop.org -site is down at the moment:(
I'll do the testing later and send the info. IF someone wants to do this earlier
(to be included in release 7?), here is the needed lshal output:

smbios.system.version = 'F.17'  (string)
system.firmware.release_date = '11/09/2005'  (string)
system.firmware.vendor = 'Hewlett-Packard'  (string)
system.firmware.version = '68BAR Ver. F.17'  (string)
system.hardware.product = 'HP Compaq nw8000 (DU322A#AK8)'  (string)
system.hardware.vendor = 'Hewlett-Packard'  (string)
system.hardware.version = 'F.17'  (string)
system.product = 'HP Compaq nw8000 (DU322A#AK8) F.17'  (string)
system.vendor = 'Hewlett-Packard'  (string)

I would perhaps recommend enabling both quirks vbemode-restore and vbestate-restore.
Comment 14 Mauri Korkeala 2007-05-23 16:41:36 EDT
I was planning to send the information to HAL -list, but surprise surprise, the
laptop doesn't resume correctly anymore with those quirks... 
Yum did update the pm-utils to  pm-utils.i686 0.99.3-6.fc7, but according to
changelog, not much changed compared to previous release. ?
I have to get back to this later and try to find out what the hell happened.
Comment 15 Zdenek Prikryl 2007-08-09 09:57:06 EDT
Is there any change or it is still does not work?

Zdenek
Comment 16 Mauri Korkeala 2007-09-06 07:56:22 EDT
Sorry for late reply, have been busy.

I have now fedora 7, with latest updates (not rawhide). Unfortunately I haven't
been able to resume the laptop correctly using quirks. I tried lots of different
combinations, including those that worked on May. It is still display that
doesn't come back up. Computer is working normally with blank screen. I can type
commands and login remotely. 

If there is some special quirk combination or other test that you want me to
try, I'll try to find time for it. I might later try how the ATI provided binary
drivers work, but I would hate to go to that direction...
Comment 17 Zdenek Prikryl 2007-09-06 09:00:38 EDT
Try to execute command "echo mem > /sys/power/state" as a root in a terminal.
This will suspend your laptop. Then try to resume it. 

Thanks
Comment 18 Mauri Korkeala 2007-09-06 09:23:57 EDT
Same results, just blank screen, but laptop is running. typing "shutdown -r 0"
reboots it nicely. Anything else?
Comment 19 Kevin Fenzi 2007-09-06 11:41:16 EDT
Any chance doing a control-alt-f1 (to switch to a vty) and then alt-f7 (to
switch back to your X session) brings back your video?
Comment 20 Mauri Korkeala 2007-09-10 15:12:44 EDT
No, it doesn't and neither does closing/opening the lid.
Comment 21 Till Maas 2008-01-06 08:47:09 EST
Can you please check whether it works now on Fedora 7? There have been some bugs
fixed lately in pm-utils, that may have broken resume for you.
Comment 22 Brian Powell 2008-04-24 23:46:42 EDT
Note that maintenance for Fedora 7 will end 30 days after the GA of Fedora 9.
Comment 23 Brian Powell 2008-04-25 00:02:29 EDT
The information we've requested above is required in order
to review this problem report further and diagnose/fix the
issue if it is still present.  Since there have not been any
updates to the report since thirty (30) days or more since we
requested additional information, we're assuming the problem
is either no longer present in the current Fedora release, or
that there is no longer any interest in tracking the problem.

Setting status to "CLOSED INSUFFICIENT_DATA".  If you still
experience this problem after updating to our latest Fedora
release and can provide the information previously requested, 
please feel free to reopen the bug report.

Thank you in advance.

Note that maintenance for Fedora 7 will end 30 days after the GA of Fedora 9.

Note You need to log in before you can comment on or make changes to this bug.