Bug 202313 - Unable to mount a vfat floppy
Summary: Unable to mount a vfat floppy
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-12 18:14 UTC by Bruno Wolff III
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-19 04:26:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bruno Wolff III 2006-08-12 18:14:21 UTC
Description of problem:
mounting a vfat formatted floppy fails.

Version-Release number of selected component (if applicable):
util-linux-2.13-0.20.4
kernel-2.6.17-1.2174_FC5

How reproducible:
100%

Steps to Reproduce:
1. mount /dev/fd0 /media/floppy
2.
3.
  
Actual results:
mount: unknown filesystem type 'vfat'

Expected results:
Successful mount

Additional info:
As far as I can tell I shouldn't have to install anything special to be able to
mount vfat floppies.
I also tried using -t msdos in case the man page was incorrect, but that didn't
work either.
This is low priority, since the floppy was written on a RH6.2 system and I redid
it again after reformatting the floppy as ext2, so it isn't blocking anything on
my end.

Comment 1 Karel Zak 2006-08-14 06:43:13 UTC
# mount /dev/fd0 /media/floppy

# mount | grep floppy
/dev/fd0 on /media/floppy type vfat (rw)

# uname -r
2.6.17-1.2174_FC5smp

# rpm -q util-linux
util-linux-2.13-0.20.4

# umount /media/floppy

# lsmod | grep fat
vfat                   16833  0
fat                    56285  1 vfat


... so, it works as expected. I think there must be some other problem. Please,
check your system logs, dmesg output and your kernel modules.


Comment 2 Bruno Wolff III 2006-08-18 14:12:52 UTC
I just noticed that I hadn't rebooted after installing 2174 and that
/lib/modules had been updated and that is most likely the cause. I don't have
the floppy here and won't be able to confirm this until tonight. However
assuming that it does work tonight, I'll close out the ticket as NOTABUG.

Comment 3 Bruno Wolff III 2006-08-19 04:26:01 UTC
I retested the floppy and it mounts now. So it looks like not having a modules
directory for the running kernel was the cause of my problems.


Note You need to log in before you can comment on or make changes to this bug.