Bug 202325 - Evolution crashes
Evolution crashes
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-12 17:08 EDT by Bob Gustafson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 13:50:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bob Gustafson 2006-08-12 17:08:45 EDT
Description of problem:

I went to open an existing message by clicking on it in my INBOX window. A
window opened up, but no content. When I clicked the 'close' box, nothing
happened. I could drag the window around, but got ugly outline marks following
the window. These did not clear up. (Evolution died, leaving a 'dumb' window on
the screen??)

Version-Release number of selected component (if applicable):

Evolution 2.6.2 according to the 'About' box.

How reproducible:

I have seen it in the past several times (over several months). When I (finally)
open up a new evolution, it works fine.

Steps to Reproduce:

1. Run Evolution for many days
2. Open up a message
3. Observe that Evolution does not respond.
4. Kill evolution (see below)
5. Restart evolution
6. Works fine.
  
Actual results:

I tried to restart evolution after the crash by clicking the Fedora toolbar
icon, but nothing happened. I then did the following:

[user1@hoho2 ~]$ ps ax | grep evol
 6699 ?        Sl     0:00 /usr/libexec/evolution-data-server-1.6
--oaf-activate-iid=OAFIID:GNOME_Evolution_DataServer_InterfaceCheck --oaf-ior-fd=51
 6711 ?        Sl     0:00 /usr/libexec/evolution/2.6/evolution-alarm-notify
--oaf-activate-iid=OAFIID:GNOME_Evolution_Calendar_AlarmNotify_Factory:2.6
--oaf-ior-fd=53
31356 ?        S      0:00 evolution
31393 pts/5    S+     0:00 grep evol
[user1@hoho2 ~]$ kill -TERM 31356
[user1@hoho2 ~]$ kill -TERM 6699
[user1@hoho2 ~]$ kill -TERM 6711

Now, again clicking on the Fedora toolbar icon is successful in restarting
evolution.



Expected results:

  Evolution should run forever without problems :-)

Additional info:

My Fedora5 is up2date as of about a week ago.
Comment 1 Bob Gustafson 2006-08-12 17:14:47 EDT
I remember a bit more:

I was successful in opening the message in my SENT mailbox (not INBOX). The
problem occurred when I went to the toolbar in the message window and did:

Message -> Edit as New Message..

It was this window that was empty and dead.

----

This evolution is running on a client connected by LAN to the host machine (Also
Fedora5 - also about a week behind in being up2date).

I am using IMAP.
Comment 2 Matthew Barnes 2006-08-12 23:05:16 EDT
Bob, thanks for the bug report.  For future reference, a sure-fire way to kill
all Evolution-related processes so that you can start fresh is to do:

    $ evolution --force-shutdown

Evolution 2.6.3 should be released to Fedora Core 5 shortly.  You might want to
try upgrading and then report back if you still experience this behavior.
Comment 3 Matthew Barnes 2006-08-24 18:00:20 EDT
Have you seen this problem again since upgrading to 2.6.3?
Comment 4 Bob Gustafson 2006-08-25 10:46:39 EDT
I did upgrade to 2.6.3 (and everything else that I have that was upgradeable -
including Kernel) lsst night.

I had some difficulty this morning - I tried to create a new message. The 'New'
button changed its color, but nothing happened after that. When I tried to
'close' the Evolution window by clicking on the upper right X, I got a dialog
box saying that it was not responding. I elected to force quit.

When I tried starting up again, I got the same symptoms as before - swirly
cursor for awhile and then normal cursor, but no Evolution. Window manager
seemed to be having trouble too.

I opened a terminal window and typed 'evolution --force-quit', not remembering
that the command should have been 'evolution --force-shutdown'. I got a wizard
dialog box - wanting me to create a new evolution configuration. I quit that.

I did the usual 'ps ax | grep evo' and found a couple of evolutions running as
well as the backend processes. I 'kill -TERM nnnnn' them all and then restarted
evolution. It seems to be running ok now. I will try to do a 'new message' in a
minute.

It seems that problems arise when more than one evolution is running. I realize
that several users can be logged into the same system and can be running
evolution in their own window space (vnc..) - this should be allowable. However,
 if I click on the Email icon on my taskbar a second time (not realizing that it
is already running..) I should not instantiate a second evolution, but cause the
running evolution to open and come to the front. This is an enhancement request.

As it is now, clicking on the Email taskbar icon brings up a NEW evolution
window, but there are no message titles shown in the INBOX window. The older
evolution window is still on the screen. This is not correct behavior.

Doing 'ps ax | grep evo' does not show any additional processes, even though
there is a second Evolution window on the screen. I don't know what is happening
there..  I can close this second window without side effects.

----

I was able to successfully create a new email and send it.
Comment 5 Matthew Barnes 2007-01-02 11:05:11 EST
Is the original problem you reported still present on Fedora Core 6 or later?
Comment 6 Matěj Cepl 2007-08-31 11:20:33 EDT
The distribution against which this bug was reported is no longer supported,
could you please reproduce this with the updated version of the currently
supported distribution (Fedora Core 6, or Fedora 7, or Rawhide)? If this issue
turns out to still be reproducible, please let us know in this bug report.  If
after a month's time we have not heard back from you, we will have to close this
bug as INSUFFICIENT_DATA.

Setting status to NEEDINFO, and awaiting information from the reporter.

Thanks in advance.
Comment 7 Matthew Barnes 2007-10-02 13:50:48 EDT
Closing as INSUFFICIENT_DATA.

Note You need to log in before you can comment on or make changes to this bug.