Bug 202329 - evolution-data-server provided library has lots of "undefined symbol"
Summary: evolution-data-server provided library has lots of "undefined symbol"
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-12 21:48 UTC by Michal Jaegermann
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: evolution-data-server-1.7.91-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 16:54:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch upstream (447 bytes, patch)
2006-08-14 16:33 UTC, Matthew Barnes
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 351317 None None None Never

Description Michal Jaegermann 2006-08-12 21:48:11 UTC
Description of problem:

After 'ldd -d -r libedataserverui-1.2.so.8' one gets 224 of
"undefined symbol" messages. Looking at those it appears that
GTK libraries are not linked while compiling.

Quoting
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=202256#c1
"The libraries work, but less efficiently than they could if they
were linked properly".

Version-Release number of selected component (if applicable):
evolution-data-server-1.7.91-1

Comment 1 Matthew Barnes 2006-08-13 03:11:47 UTC
Michal, thanks for the bug report.

Looks like they're all GTK+ symbols.  That should make it easier to track down.
 I'll investigate.

Comment 2 Matthew Barnes 2006-08-14 16:33:39 UTC
Created attachment 134151 [details]
Proposed patch upstream

Comment 3 Matthew Barnes 2006-08-14 16:54:57 UTC
Fixed in evolution-data-server-1.7.91-2.


Note You need to log in before you can comment on or make changes to this bug.