Bug 202332 - Eclipse does not work with default installation.
Eclipse does not work with default installation.
Status: CLOSED DUPLICATE of bug 201778
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ben Konrath
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-12 18:50 EDT by Steve Milner
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-12 19:18:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Steve Milner 2006-08-12 18:50:17 EDT
Description of problem:
Trying to run eclipse results in the following error:
JVM terminated. Exit code=127
/usr/bin/java
-jar startup.jar
-os linux
-ws gtk
-arch x86
-launcher /usr/bin/eclipse
-name Eclipse
-showsplash 600
-exitdata 11800d
-vm /usr/bin/java
-vmargs
-jar startup.jar 

Running from the console yeilds the following information:

/usr/bin/java: symbol lookup error:
/usr/share/eclipse/configuration/org.eclipse.osgi/bundles/36/1/.cp/libswt-mozilla-gtk-3232.so:
undefined symbol: NS_InitEmbedding

Version-Release number of selected component (if applicable):
[steve@minilinux ~]$ rpm -qa | grep eclipse
eclipse-platform-3.2.0-1jpp_11fc
eclipse-pde-runtime-3.2.0-1jpp_11fc
eclipse-ecj-3.2.0-1jpp_11fc
eclipse-jdt-3.2.0-1jpp_11fc
eclipse-cdt-3.1.0-1jpp_11fc
eclipse-bugzilla-0.2.2-8
eclipse-rcp-sdk-3.2.0-1jpp_11fc
eclipse-changelog-2.2.0-2.fc6
eclipse-rcp-3.2.0-1jpp_11fc
eclipse-pydev-0.9.3_fc-17
eclipse-jdt-sdk-3.2.0-1jpp_11fc
eclipse-pde-3.2.0-1jpp_11fc
eclipse-platform-sdk-3.2.0-1jpp_11fc

How reproducible:
For me it happens everytime ...

Steps to Reproduce:
1. yum install the above rpms
2. run eclipse from a launcher
3. run eclipse from the command line to see the lib error
  
Actual results:
JVM terminated. Exit code=127
/usr/bin/java
-jar startup.jar
-os linux
-ws gtk
-arch x86
-launcher /usr/bin/eclipse
-name Eclipse
-showsplash 600
-exitdata 11800d
-vm /usr/bin/java
-vmargs
-jar startup.jar 

/usr/bin/java: symbol lookup error:
/usr/share/eclipse/configuration/org.eclipse.osgi/bundles/36/1/.cp/libswt-mozilla-gtk-3232.so:
undefined symbol: NS_InitEmbedding


Expected results:
Eclipse to start up

Additional info:
This is i386 running on a mac mini (intel dual core).

[steve@minilinux ~]$ rpm -qa | grep java
java-1.4.2-gcj-compat-1.4.2.0-40jpp_100rh
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_100rh
ant-javamail-1.6.5-2jpp.1
java-1.4.2-gcj-compat-plugin-1.4.2.0-40jpp_100rh
gcc-java-4.1.1-14
java-1.4.2-gcj-compat-javadoc-1.4.2.0-40jpp_100rh

[steve@minilinux ~]$ rpm -qa | grep gcj
java-1.4.2-gcj-compat-1.4.2.0-40jpp_100rh
libgcj-4.1.1-14
libgcj-devel-4.1.1-14
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_100rh
java-1.4.2-gcj-compat-plugin-1.4.2.0-40jpp_100rh
java-1.4.2-gcj-compat-javadoc-1.4.2.0-40jpp_100rh
Comment 1 Ben Konrath 2006-08-12 19:18:21 EDT

*** This bug has been marked as a duplicate of 201778 ***

Note You need to log in before you can comment on or make changes to this bug.