Bug 202339 - TV card connected to Line-In of ADI-1988B Sound chip produces no sound
TV card connected to Line-In of ADI-1988B Sound chip produces no sound
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-12 21:26 EDT by Dick Gingras
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.6.18-1.2784.fc6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-15 11:26:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dick Gingras 2006-08-12 21:26:16 EDT
Description of problem:


Version-Release number of selected component (if applicable):
2.6.17-1.2157_FC5 and previous kernels, snd-hda-intel module, +bttv +msp3400
+tvaudio

How reproducible:
Always

Steps to Reproduce:
1. plug TV output into Line-In on back of motherboard
2. run tvtime with speakers on
3.
  
Actual results:
No sound from speakers

Expected results:
Sound from speakers

Additional info:
None of the volume controls in the Alsa Mixer cause any change to occur - sound
is totally absent; same thing using kmix and alsa-mixer. The hardware works in
Windows XP.

Plugging headphones directly into the TV board doesn't work either, so this may
be a problem with the tvaudio or msp3400 modules.

The problem first appeared in FC4 with kernel 2.6.16-1.2115_FC4, but sound was
(and still is) produced using headphones plugged into the TV board's line-out.

The same results as for FC5 are produced with FC6-test2, kernel
2.6.17-1.2548.fc6 and previous versions.

Hardware:
Asus M2N32 SLI Deluxe motherboard with ADI-1988B sound chip
AMD Athlon X2 4000
2 GB DDR2-800 memory
Hauppauge WinTV dbx 401
Comment 1 Ronald Wahl 2006-10-03 06:15:22 EDT
I can reproduce this here with FC5 on an Asus P5B with ADI-1988B and Hauppauge
WinTV. Neither vmlinuz-2.6.17-1.2187_FC5smp nor 2.6.18-1.2189.fc5smp (from
updates/testing) is working. The TV card generates a signal on it's line-out so
there must be a problem with the mixer.
Comment 2 Dick Gingras 2006-10-15 11:26:56 EDT
The problem has been fixed between 2.6.18-1.2693.fc6 (didn't work) and
2.6.18-1.2784.fc6 (now works). I didn't try any kernels in between those two, so
I can't say which version contained the fix.

Also, stereo sound is now working correctly, so this bttv version also fixed a
separate problem where switching between two stations, one with stereo and one
with mono, would lose the sound entirely, but could be corrected by selecting
Setup -> Input Configuration -> Preferred Audio Mode and switching from Stereo
to Mono and back again.
Comment 3 Ronald Wahl 2006-10-31 19:09:19 EST
I still have the problem with the stock FC6 kernel (2.6.18-1.2798.fc6) which is
newer than 2.6.18-1.2784.fc6. Can someone reopen respective fix the bug, please?
Thx!
Comment 4 Dick Gingras 2006-10-31 19:20:14 EST
I'm also using 2.6.18-1.2798.fc6, but it still works for me.

After a reboot, TVTime gives a "No Signal" error until I do the following:

rmmod bttv bt878
modprobe bttv

and sometimes this needs to be done more than once (race condition?). But the
sound does work after this magic incantation.
Comment 5 Ronald Wahl 2006-10-31 19:45:39 EST
Ok, thx for your comment but this does not help in my case. But nevertheless even
if this would work it does not fix the line-in problem. The output of the TV Card
(which definitely has a signal) is connected to the line-in of the on-board sound
hardware but I do not hear anything. I played long time with alsamixer but with no
success. Reloading bttv related modules cannot fix this because they are not
related to the on-board sound hardware.
Comment 6 Ronald Wahl 2006-11-01 17:08:41 EST
I got it working: I had to add a module parameter: model="3stack"

e.g. options snd-hda-intel index=0 model="3stack"

After this I enabled the analog mixing and then was able to hear sound from tv
card. There are other models avaliable. I just looked at the driver source to
get this idea. 

Note You need to log in before you can comment on or make changes to this bug.