This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 202340 - gnomebaker icon won't theme
gnomebaker icon won't theme
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gnomebaker (Show other bugs)
5
All Linux
low Severity low
: ---
: ---
Assigned To: Brian Pepple
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-12 23:45 EDT by Jeff Moe (jebba)
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-30 19:54:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Moe (jebba) 2006-08-12 23:45:37 EDT
The icon in the menu does not change when the theme is changed. This
is true even if the theme has an icon of the correct name.

The cause of this is that in
/usr/share/applications/fedora-gnomebaker.desktop
the Icon= line has the absolute path to the icon instead of just the
icon name.

It has:
Icon=/usr/share/gnomebaker/gnomebaker-48.png

When it should have:
Icon=gnomebaker-48.png
Comment 1 Brian Pepple 2006-08-13 00:37:33 EDT
To correct this will take more work than just modifing the desktop file, since
the icons aren't installed in the '$(datadir)/icons/hicolor/' directory to make
use of the gtk-icon-cache.  Also, some of the src files will need to be
modified, since the current icon paths are hardcoded.  Some of the steps
involved to fix this are documented here:

http://live.gnome.org/GnomeGoals/AppIcon

I'll work up a patch for upstream when I get some free time, but I'm not going
to be backporting a patch to 0.5.1.



Comment 2 Brian Pepple 2006-08-30 19:54:17 EDT
Looks like my initial patch has been applied upstream.  I'm not going to be
backporting these changes to FC5, but it sounds like Bid should be doing a new
release for GnomeBaker soon, and should make it into FC6 eventually.

https://sourceforge.net/tracker/?func=detail&atid=708501&aid=1540113&group_id=127397

Note You need to log in before you can comment on or make changes to this bug.