Bug 202344 - Display size detection problem
Display size detection problem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Jackson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-13 05:34 EDT by David Bentley
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-13 08:55:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
info as requested (52.53 KB, application/x-gzip)
2006-08-31 09:19 EDT, David Bentley
no flags Details

  None (edit)
Description David Bentley 2006-08-13 05:34:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.8.0.6) Gecko/20060808 Fedora/1.5.0.6-2.fc5 Firefox/1.5.0.6 pango-text

Description of problem:
At boot if monitor (SAMSUNG SyncMaster 701N) not attached (via KVMswitch) to the system login screen defaults to large size (1920 x 1200) and if connected it gets setup as (1400 x 1050). The native display size is 1280 x 1024 and I notice that no display sizes get specified in X11.conf anymore.

Also at install the monitor was not detected correctly I had to select it from the list but this only worked after the first set of updates and I think I had to wait for the next updates before you could specify the video card.

Once loged in you can set the users display size and refresh rate but it defaults at the next login to the highest available refresh rate for the given resolution. (see bug 176326)

On previous installs at first boot you got the opertunity to set the maximum display size and color depth but this was not the case for FC6test2 so are we now dynomically detecting monitot capabilities at each boot and if so this will cause problems where people like me use one monitor for several systems va a KVM switch

Version-Release number of selected component (if applicable):
current as of 10/8/06 and apparent since FC6test2 install

How reproducible:
Always


Steps to Reproduce:
see description

Actual Results:
see description

Expected Results:
Some mechanism to fix expected monitor size at boot (it was previously done in the x11.conf file)

Additional info:
Comment 1 David Bentley 2006-08-28 18:09:55 EDT
Adding back the following in xorg.conf (annotates **) cures the problem.

# Xorg configuration created by system-config-display

Section "ServerLayout"
	Identifier     "single head configuration"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
	Option	    "XkbModel" "pc105"
	Option	    "XkbLayout" "gb"
EndSection

Section "Monitor"
	Identifier   "Monitor0"
	ModelName    "Samsung SyncMaster 710N/177N/CX711N/CX701N"
 ### Comment all HorizSync and VertSync values to use DDC:
	HorizSync    30.0 - 81.0
	VertRefresh  56.0 - 85.0
	Option	    "dpms"
EndSection

Section "Device"
	Identifier  "Videocard0"
	Driver      "nv"
EndSection

Section "Screen"
	Identifier "Screen0"
	Device     "Videocard0"
	Monitor    "Monitor0"
	DefaultDepth     24
**	SubSection "Display"
**		Viewport   0 0
**		Depth	  24
**		Modes	 "1280x1024"
**	EndSubSection
EndSection

Comment 2 Adam Jackson 2006-08-29 12:02:59 EDT
Can you attach the Xorg.0.log from a startup without the extra Display subsection?
Comment 3 David Bentley 2006-08-31 09:19:16 EDT
Created attachment 135284 [details]
info as requested

See attachment info as requested.
Comment 4 David Bentley 2006-08-31 09:43:26 EDT
Note between the iniial re-creation of the xorg.conf file and the .1 logfie and
between the creations of .1 and .2 and between .3 and .4 and between .4 and .5
the system was restarted.

The monitor was specified after the creation of .3 log file by running
s-c-display and the resulting new xorg.conf file (4-6) being saved before
restarting the system.
Comment 5 Adam Jackson 2006-08-31 10:47:02 EDT
Well for one, you're getting the sync ranges wrong in the config file, which is
assuredly giving you a much larger range of bad modes than you'd normally see:

	HorizSync    30.0 - 81.0
	VertRefresh  56.0 - 85.0

Versus:

(II) NV(0): Ranges: V min: 56  V max: 75 Hz, H min: 30  H max: 81 kHz, PixClock
max 140 MHz

That appears to be a bug in the MonitorsDB list though, which should be fixed in
0.187 which I just pushed.  I'm definitely seeing the resolution selection bug
now though, working on it.
Comment 6 Till Maas 2006-12-04 21:30:12 EST
Is this bug resolved now? Then please close it :-)
Comment 7 David Bentley 2007-05-13 08:55:31 EDT
Closing as resolved in RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.