Bug 2023477 - SE Linux warning popped up.
Summary: SE Linux warning popped up.
Keywords:
Status: CLOSED DUPLICATE of bug 2022690
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 35
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Zdenek Pytela
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-11-15 20:19 UTC by mister_t_stauss
Modified: 2021-11-16 13:54 UTC (History)
0 users

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2021-11-16 13:54:45 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)

Description mister_t_stauss 2021-11-15 20:19:22 UTC
Description of problem:After update, SE Linux warning was received that SE Linux prevented sss_cache from using the setgid capability. I am filing bug report per warning suggestion, and I also generated a local policy to permit the sss_cache to use the setgid capability, per that same warning note.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info: SE Warning as follows: SELinux is preventing sss_cache from using the setgid capability.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that sss_cache should have the setgid capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'sss_cache' --raw | audit2allow -M my-ssscache
# semodule -X 300 -i my-ssscache.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:useradd_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:useradd_t:s0-s0:c0.c1023
Target Objects                Unknown [ capability ]
Source                        sss_cache
Source Path                   sss_cache
Port                          <Unknown>
Host                          fedora
Source RPM Packages           
Target RPM Packages           
SELinux Policy RPM            selinux-policy-targeted-35.5-1.fc35.noarch
Local Policy RPM              selinux-policy-targeted-35.5-1.fc35.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     fedora
Platform                      Linux fedora 5.14.17-301.fc35.x86_64 #1 SMP Mon
                              Nov 8 13:57:43 UTC 2021 x86_64 x86_64
Alert Count                   2
First Seen                    2021-11-15 14:50:32 EST
Last Seen                     2021-11-15 14:50:32 EST
Local ID                      a230b8c7-996c-4ddb-9407-c7e4994e16ea

Raw Audit Messages
type=AVC msg=audit(1637005832.895:276): avc:  denied  { setgid } for  pid=3491 comm="sss_cache" capability=6  scontext=unconfined_u:unconfined_r:useradd_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:useradd_t:s0-s0:c0.c1023 tclass=capability permissive=0


Hash: sss_cache,useradd_t,useradd_t,capability,setgid

Comment 1 Zdenek Pytela 2021-11-16 13:54:45 UTC

*** This bug has been marked as a duplicate of bug 2022690 ***


Note You need to log in before you can comment on or make changes to this bug.