Bug 202353 - Firefox 1.5.0.5 startup script not updated for the add-on based locale
Firefox 1.5.0.5 startup script not updated for the add-on based locale
Status: CLOSED DUPLICATE of bug 202352
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: firefox (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-13 11:49 EDT by Yue Shi Lai
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-24 09:17:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yue Shi Lai 2006-08-13 11:49:19 EDT
Description of problem:

Firefox 1.5.0.5 uses a add-on based locale support. However, /usr/bin/firefox 
still expects the locale file to be located in the old filesystem layout, and 
is unable to locate any locale beside en_US. Therefore, Firefox will start up 
in en_US locale regardless of the system locale settings.

Version-Release number of selected component (if applicable):

1.5.0.5-0.el4.1

How reproducible:

Always.

Steps to Reproduce:
1. Set e.g. LANG=de_DE.UTF-8
2. Run /usr/bin/firefox
3.
  
Actual results:

Firefox starts in the US English locale, regardless of $LANG.

Expected results:

Firefox should start in the locale specified by $LANG, as long as there is an 
Firefox langauge add-on present.

Additional info:

This problem can be easily fixed by updating /usr/bin/firefox, line 142 from:

[ -f $MOZILLA_FIVE_HOME/chrome/$MOZLOCALE.jar ] && MOZARGS="-UILocale 
$MOZLOCALE"

to:

[ -f $MOZILLA_FIVE_HOME/extensions/langpack-${MOZLOCALE}@firefox.mozilla.org/
chrome/$MOZLOCALE.jar ] && MOZARGS="-UILocale $MOZLOCALE"
Comment 1 Bastien Nocera 2006-08-24 09:17:19 EDT

*** This bug has been marked as a duplicate of 202352 ***

Note You need to log in before you can comment on or make changes to this bug.