Bug 202366 - freetype-config --libs returns invalid rpath.
freetype-config --libs returns invalid rpath.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: freetype (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-13 14:06 EDT by Mamoru TASAKA
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-13 17:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2006-08-13 14:06:22 EDT
Description of problem:
executing "freetype-config --libs" shows "-L/usr/include -Wl,--rpath
-Wl,/usr/include -lfreetype", which contains a invalid rpath
"/usr/include".

Rebuiling ImageMagick with fedora-rpmdevtools fails because
rebuiling ImageMagick calls "freetype-config" in configure and 
uses the result, which annoys /usr/lib/rpm/check-rpaths 
when "/usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot" is called.

Version-Release number of selected component (if applicable):
freetype-devel-2.2.1-3

How reproducible:
100%

Steps to Reproduce:
1. execute "freetype-config --libs"
2.
3.
  
Actual results:
returns "-L/usr/include -Wl,--rpath -Wl,/usr/include -lfreetype",
which is not correct.

Expected results:
On FC5 (freetype-devel-2.1.10-5.2.1), it returns
"-lfreetype -lz"

Additional info:
/usr/bin/freetype-config includes the line:
libdir=`pkg-config --variable includedir freetype2`
This must be:
libdir=`pkg-config --variable libdir freetype2` , perhaps?
Comment 1 Mamoru TASAKA 2006-08-13 14:33:22 EDT
Even it is corrected so that "freetype-config --libs" returns
-L/usr/include -Wl,--rpath -Wl,/usr/lib -lfreetype", including a standard
rpath such as "/usr/lib" would not be recommended (I am not sure).
Comment 2 Matthias Clasen 2006-08-13 17:02:51 EDT
fixed in 2.2.1-4.fc6

Note You need to log in before you can comment on or make changes to this bug.