Bug 202367 - Slab errors in dmesg log with FC6-T2 including 2.6.17-1.2611.fc6
Slab errors in dmesg log with FC6-T2 including 2.6.17-1.2611.fc6
Status: CLOSED DUPLICATE of bug 160878
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks: FC6Test3Blocker
  Show dependency treegraph
 
Reported: 2006-08-13 14:17 EDT by Dave Russell
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 01:45:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg log showing errors and backtraces. (119.77 KB, text/plain)
2006-08-13 14:17 EDT, Dave Russell
no flags Details
dmesg log showing slab errors (20.94 KB, text/plain)
2006-09-03 08:48 EDT, Dave Russell
no flags Details

  None (edit)
Description Dave Russell 2006-08-13 14:17:01 EDT
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Happens every time, from install and when updated to latest kernel.

Steps to Reproduce:
1. Install FC6 T2
2. Watch errors flood the dmesg log
  
Actual results:
dmesg log full of slab errors
e.g.

[1]
f7c030b8: redzone 1:0x170fc2a5, redzone 2:0x10001000.
slab error in verify_redzone_free(): cache `i2o_iop0_msg_inpool': memory outside
object was overwritten

and

[2]
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:

Expected results:
None of these errors should be happening.

Additional info:
There are errors from the initial FC6-T2 kernel, and on the current dev kernel.

[dave@xxxx ~]$ uname -a
Linux xxxx.xxxx.xxxx 2.6.17-1.2558.fc6 #1 SMP Sat Aug 12 19:13:51 EDT 2006 i686
athlon i386 GNU/Linux
Comment 1 Dave Russell 2006-08-13 14:17:05 EDT
Created attachment 134104 [details]
dmesg log showing errors and backtraces.
Comment 2 Dave Russell 2006-09-02 10:55:02 EDT
uname -a
Linux localhost.localdomain 2.6.17-1.2608.fc6 #1 SMP Thu Aug 31 05:55:45 EDT
2006 i686 athlon i386 GNU/Linux


Still present:

input: Microsoft Natural� Ergonomic Keyboard 4000 as /class/input/input10
input: USB HID v1.11 Device [Microsoft Natural� Ergonomic Keyboard 4000] on
usb-0000:00:10.0-2.1.3
PM: Adding info for No Bus:usbdev2.9_ep82
Slab corruption: (Not tainted) start=f7ea832c, len=2048
Redzone: 0x5a2cf071/0x5a2cf071.
Last user: [<c0532450>](release_mem+0x1fd/0x204)
 [<c04051ee>] show_trace_log_lvl+0x58/0x159
 [<c04057ea>] show_trace+0xd/0x10
 [<c0405903>] dump_stack+0x19/0x1b
 [<c046df8a>] check_poison_obj+0x6d/0x172
 [<c046e20f>] cache_alloc_debugcheck_after+0x28/0x147
 [<c046f6a7>] kmem_cache_alloc+0xa9/0xb5
 [<c053223d>] alloc_tty_struct+0x13/0x29
 [<c05324da>] init_dev+0x83/0x498
 [<c0534e21>] tty_open+0x11b/0x308
 [<c047adab>] chrdev_open+0x105/0x13a
 [<c04719c6>] __dentry_open+0xc8/0x1ab
 [<c0471b17>] nameidata_to_filp+0x1c/0x2e
 [<c0471b57>] do_filp_open+0x2e/0x35
 [<c0471b9e>] do_sys_open+0x40/0xb5
 [<c0471c3f>] sys_open+0x16/0x18
 [<c0403faf>] syscall_call+0x7/0xb
DWARF2 unwinder stuck at syscall_call+0x7/0xb
Leftover inexact backtrace:
 [<c04057ea>] show_trace+0xd/0x10
 [<c0405903>] dump_stack+0x19/0x1b
 [<c046df8a>] check_poison_obj+0x6d/0x172
 [<c046e20f>] cache_alloc_debugcheck_after+0x28/0x147
 [<c046f6a7>] kmem_cache_alloc+0xa9/0xb5
 [<c053223d>] alloc_tty_struct+0x13/0x29
 [<c05324da>] init_dev+0x83/0x498
 [<c0534e21>] tty_open+0x11b/0x308
 [<c047adab>] chrdev_open+0x105/0x13a
 [<c04719c6>] __dentry_open+0xc8/0x1ab
 [<c0471b17>] nameidata_to_filp+0x1c/0x2e
 [<c0471b57>] do_filp_open+0x2e/0x35
 [<c0471b9e>] do_sys_open+0x40/0xb5
 [<c0471c3f>] sys_open+0x16/0x18
 [<c0403faf>] syscall_call+0x7/0xb
0c0: 6b 6b 6b 6b 6b 6b 6b 6b ff ff ff ff 00 00 00 00
Next obj: start=f7ea8b38, len=2048
Redzone: 0x170fc2a5/0x170fc2a5.
Last user: [<c05f2c13>](devinet_sysctl_register+0x2b/0x128)
000: 6c 46 ba c1 01 00 00 00 0b 3d 66 c0 58 f7 ee f7
010: 04 00 00 00 a4 01 00 00 00 00 00 00 b2 23 5f c0
ip6_tables: (C) 2000-2006 Netfilter Core Team
Netfilter messages via NETLINK v0.30.
ip_conntrack version 2.4 (8192 buckets, 65536 max) - 228 bytes per conntrack
ip_tables: (C) 2000-2006 Netfilter Core Team
process `sysctl' is using deprecated sysctl (syscall)
net.ipv6.neigh.eth0.base_reachable_time; Use
net.ipv6.neigh.eth0.base_reachable_time_ms instead.
Bluetooth: Core ver 2.10
Comment 3 Dave Russell 2006-09-02 11:02:59 EDT
Modified summary to take account of updated kernel
Comment 4 Dave Russell 2006-09-03 08:48:21 EDT
Created attachment 135456 [details]
dmesg log showing slab errors
Comment 5 Dave Russell 2006-09-03 08:50:01 EDT
Modified summary to reflect having tested updated kernel
Comment 6 Dave Jones 2006-09-14 01:45:25 EDT

*** This bug has been marked as a duplicate of 160878 ***

Note You need to log in before you can comment on or make changes to this bug.