Bug 202391 - Red Hat products list too cluttered
Red Hat products list too cluttered
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
3.6
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
Kevin Baker
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-13 23:16 EDT by Jens Petersen
Modified: 2014-12-01 18:08 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-10 09:10:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2006-08-13 23:16:17 EDT
Description of problem:
https://bugzilla.redhat.com/bugzilla/enter_bug.cgi
page products list is too cluttered.

The main products like RHEL and Fedora Core should be listed separately
at the top to make it easy to navigate.
Comment 1 David Lawrence 2008-09-16 12:54:49 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 2 Jens Petersen 2008-09-16 21:20:05 EDT
This improved now with links to separate Red Hat and Fedora product pages.

But the Red Hat products page is still too cluttered IMHO and a bit daunting for newcomers and customers.  The most important and common products should be listed separately at the top or even on the top page?
Comment 3 Chris Ward 2009-04-02 02:21:36 EDT
I vote - here (CLOSE), i think users know which product they are looking to file a bug against. They're pretty smart. All modern browsers provide pretty easy page search (ctrl f) functionality too.
Comment 4 Alasdair Kergon 2009-04-24 19:06:10 EDT
The right-justified formatting also makes this problem worse IMHO, making it hard to scan down the page once you've selected 'Red Hat'.

I think the top-level Red Hat/Fedora/Other page should have another section added containing direct links to the most commonly-used Products - there's plenty of room for this.
Comment 5 Noura El hawary 2009-04-28 07:20:20 EDT
If we add another classification to the current ones we already have like adding 'Most Used Products' classification and then we add to that for example Fedora and RHEL 5 products this will remove those products from the other classifications which are RedHat and Fedora as a product can belong to only one classification, not sure of we want to do that as this might confusion to other users, also i think most used products differ from one user to another.

Noura
Comment 6 Chris Ward 2009-04-28 07:57:01 EDT
Sounds like a lot of trouble...imo, i would close this as WONTFIX until at least one other person complains. 

Unless, could you just add a free form / munual text box which held 'the most important products'? One that was just manually edited into the page and edited by hand? still sounds like a lot of work, in terms of maintenance. But at least it wouldn't require reworking the categories and such.
Comment 7 Alasdair Kergon 2009-04-28 09:40:47 EDT
I meant hard-coding links into the page template (assuming that page has a separate one) rather than moving them in the database structure.

You can get a rough idea of 'most used' with some simple database queries of course, but I was thinking the main RHEL, Fedora, JBoss releases etc.
Comment 8 David Lawrence 2010-01-15 12:33:30 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.
Comment 9 David Lawrence 2010-08-25 17:41:59 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 11 Simon Green 2012-05-10 09:10:15 EDT
While it is possible to modify the layout of the product list (like bugzilla.mozilla.org does), I agree with Chris's comments that Bugzilla users are a pretty clever bunch.

It's 5½ years since this bug was filed, and in the 1½ that I've worked on Bugzilla, I haven't had this raised as an issue.

  -- simon

Note You need to log in before you can comment on or make changes to this bug.