Bug 202393 - Intermittent named crash with pthread_mutex_destroy
Intermittent named crash with pthread_mutex_destroy
Status: CLOSED DUPLICATE of bug 173961
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: bind (Show other bugs)
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Adam Tkac
Ben Levenson
: 202394 (view as bug list)
Depends On:
  Show dependency treegraph
Reported: 2006-08-14 00:12 EDT by James Gardiner
Modified: 2013-04-30 19:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-03-06 11:37:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description James Gardiner 2006-08-14 00:12:37 EDT
Description of problem:

Very occasionally (particularly under load) named will crash with one ofthe 
following (or similar)

RUNTIME_CHECK(((pthread_mutex_destroy(((&adb->mplock))) == 0
) ? 0 : 34) == 0) failed
14:37:45.515 RUNTIME_CHECK(((pthread_mutex_destroy(((&rbtdb->node_locks[i
].lock))) == 0) ? 0 : 34) == 0) failed

I don't believe this is related to memory constraints, since the busiest server 
never exceeds a resident footprint of 250MB, whereas these servers have 2GB RAM 
and  are exclusively for DNS.

Version-Release number of selected component (if applicable):
Kernel 2.6.9-34.0.2.ELsmp x86_64

How reproducible:
Happened about four times in eight months (so not very :< )

Steps to Reproduce:
1. Run bind on an SMP x86_64 box.
2. ?

Additional info:
This is essentially the same issue as bug 173961, which was closed as it claims 
a fix has been implemeneted in back-ports from Bind 9.2.6 to 9.2.4, but we are 
running 9.3.2.
Comment 1 Martin Stransky 2006-08-14 04:34:41 EDT
*** Bug 202394 has been marked as a duplicate of this bug. ***
Comment 2 Martin Stransky 2006-10-13 11:34:10 EDT
bind-9.3.2-2_EL4 isn't supported by Red Hat, it's only a test package...
Comment 3 Adam Tkac 2007-03-06 11:37:26 EST
This is fixed in RHEL-4.4 so if you want use bind 9.3 series or newer please use
packages from Fedora. bind 9.3.2 isn't supported in RHEL-4 => closing

Regards, Adam

*** This bug has been marked as a duplicate of 173961 ***

Note You need to log in before you can comment on or make changes to this bug.