Bug 202414 - Implement plugins
Implement plugins
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: vsftpd (Show other bugs)
rawhide
All Linux
medium Severity low
: ---
: ---
Assigned To: Jiri Skala
: FutureFeature, Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 06:11 EDT by Patrick Monnerat
Modified: 2014-11-09 17:30 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-03-16 05:45:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to imlement plugins (28.17 KB, patch)
2006-08-14 06:11 EDT, Patrick Monnerat
no flags Details | Diff
Patch to implement plugins (against vsftpd-2.0.7-1.fc10.src.rpm) (28.27 KB, patch)
2008-11-24 09:43 EST, Patrick Monnerat
no flags Details | Diff
Patch to implement plugins (against vsftpd-2.2.0-5) (28.57 KB, patch)
2009-11-20 14:52 EST, Patrick Monnerat
no flags Details | Diff

  None (edit)
Description Patrick Monnerat 2006-08-14 06:11:18 EDT
Description of problem: Need of various extra operations upon file
send/receive/rename. This is an extension path proposal, not a bug report.
Submitted here, because upstream does not answer.


Version-Release number of selected component (if applicable): 2.0.4-1.2


Additional info:
The attached patch implements a plugin feature. A plugin .so library is called
before and after a file is sent/received/deleted/renamed or a directory is
created/deleted/renamed.
It is particularly useful to perform some extra permission checking, statistics,
 active file processing, etc.
See file PLUGINS after apply patch for a usage description.
Comment 1 Patrick Monnerat 2006-08-14 06:11:18 EDT
Created attachment 134123 [details]
Patch to imlement plugins
Comment 2 Maros Barabas 2006-08-15 05:58:08 EDT
Thanks for patch, I'll append it, but it could be earliest in fedora core 7.
Comment 3 Patrick Monnerat 2006-08-15 07:29:28 EDT
Many thanks. If you do so, I will suggest to create a package vsftpd-devel with 
the following files:

/usr/include/vsftpd/plugins.h
/usr/share/doc/vstpd-devel-x.y.z/COPYING
/usr/share/doc/vstpd-devel-x.y.z/PLUGINS

to allow easy plugin development.
Comment 4 Patrick Monnerat 2007-05-30 06:26:46 EDT
... by looking at the development packages, it seems it will NOT be included in
Fedora 7 ...
Are there some plans to really include it ?
Comment 5 Maros Barabas 2007-08-27 09:57:23 EDT
Hi, sorry but this plugins could be implemented in Fedora 9 and later after
testing version. Upstream doesn't answer a long time so we have to make review,
test package and a lot of tests. Sorry for this long process.
Comment 6 Patrick Monnerat 2007-08-27 13:11:37 EDT
Yes, upstream site seems abandoned. This is a pity because the product is good.
I hope I'm wrong, ot that someone else will make it live again.
Anyway, I'm running FC6 for now and ported this patch to the FC6 version (2.0.5-
10): I'm using it daily (in a prod server) and it did not need real update 
since FC6 early days.
When you need the patch for 2.0.5-10, just ask here !
Thanks for your interest
Comment 7 ofir_144 2008-09-05 17:21:38 EDT
Will functions that are called using this plugin be able to access files out of the chroot? (e.g. /bin/sh )
Comment 8 Patrick Monnerat 2008-09-29 08:42:10 EDT
No. They are called directly. Plugin library is loaded dynamically (dlopen), plugin function addresses are latched, then called when needed, thus being executed in the same context as the server process. No fork/exec is performed.
Comment 9 Patrick Monnerat 2008-11-24 09:43:05 EST
Created attachment 324485 [details]
Patch to implement plugins (against vsftpd-2.0.7-1.fc10.src.rpm)

Applicable as is to vsftpd-2.0.7-1.fc10.src.rpm after all other patches.
Comment 10 Patrick Monnerat 2009-11-20 14:52:27 EST
Created attachment 372593 [details]
Patch to implement plugins (against vsftpd-2.2.0-5)

This version of the patch fixes compilation problems on 64-bit architectures
Comment 11 Jiri Skala 2010-01-19 03:56:12 EST
Upstream communicates over one year again. I've sent the patch to Chris Evans aprox. half a year ago. I don't plan to add this patch independently of upstream.

Jiri
Comment 12 Jiri Skala 2010-03-16 05:45:54 EDT
Upstream has obtained this patch therefore I don't see any reason to keep the bug opened in accordance to comment 11.

Note You need to log in before you can comment on or make changes to this bug.