Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: NNCP fails w the following: libnmstate.error.NmstateLibnmError: Activate profile uuid:1696490a-8f2e-4ba6-844e-21db9c631cd1 iface:eno1.2032 type: vlan failed: error=nm-manager-error-quark: Failed to find a compatible device for this connection (3) Version-Release number of selected component (if applicable): 4.8.2 How reproducible: unsure Steps to Reproduce: 1. spin up a 3-node cluster 2. install CNV 3. create an NNCP and apply it Actual results: fails w libnmstate.error.NmstateLibnmError above Expected results: NNCP applies correctly w/o error/issue Additional info: my understanding of CNV was that the NMstate operator was required, however NMstate operator has not been installed
Hello, As per the customer, nmstate isn't behaving as expected. They have a parent interface which doesn't get identified properly and any VLAN interfaces (e.g. eno1.1234) bound to the parent device (e.g. eno1) via NNCP cause nmstate not to find the parent device. As a workaround, the customer is reporting that they need to remove any sub-interfaces bound to the parent first in the NNCP, then modify NNCP again to then re-enable the sub-interfaces, but this causes their VMs to lose networking. Also, is NM supposed to identify connection names = to device names (e.g. eno1) ... This is not the case since connection name = "Wired Connection" and device in some cases shows -- rather than eno1. We even tried to explicitly define the parent device in the NNCP but it doesn't seem to recover well in the event of a node reboot. Questions: - Can you comment on the case on the correct way to ensure that devices are configured including how to configure the NNCP so that things come up properly on reboot? - How should the base networkmanager configuration be defined? - Should the NNCP include any parent device configuration as well? - Why is the default NM configuration not identifying the parent devices so that the sub-interfaces defined in the NNCP can properly bind to them? Is there an NM issue or so specific NM configuration that needs to be applied to each node manually ? Thanks!
Thanks @phoracek I'll pass on these suggestions and we'll reply with more questions, if needed.
I removed the needinfo from https://bugzilla.redhat.com/show_bug.cgi?id=2024249#c10 by mistake, we still need those logs.
Since there was no update in the last month, I'm closing this as INSUFFICIENT_DATA. If you manage to gather more info, please feel free to reopen this.
The needinfo request[s] on this closed bug have been removed as they have been unresolved for 500 days