Bug 202427 - Unable to mount filesystems after kernel update to 2.6.9-42
Unable to mount filesystems after kernel update to 2.6.9-42
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
4.0
ia64 Linux
medium Severity high
: ---
: ---
Assigned To: Alasdair Kergon
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 08:30 EDT by VikkiW
Modified: 2010-01-11 21:26 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-15 09:49:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output from dmsetup commands (4.38 KB, text/plain)
2006-08-15 02:51 EDT, VikkiW
no flags Details

  None (edit)
Description VikkiW 2006-08-14 08:30:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Description of problem:
After upgrading to AS4 Update 4 kernel and rebooting, any filesystems not on the same disk as / are unable to be mounted.

# mount /other
mount: LABEL=/other duplicate - not mounted
# mount /dev/sdb1 /other
mount: /dev/sdb1 already mounted or /other busy

Even after reformating disk, I cannot mount the new filesystem to a newly created directory.

Version-Release number of selected component (if applicable):
kernel-2.4.9-42.EL

How reproducible:
Always


Steps to Reproduce:
1. Boot to kernel-2.6.9-42.EL
2. Try to mount filesystems
3.

Actual Results:
# mount /dev/sdb1 /other
mount: /dev/sdb1 already mounted or /other busy

Expected Results:
The filesystem should have been mounted.

Additional info:
If I boot to the previous kernel version (2.6.9-34.0.2.EL) I can mount the filesystems without problems.
Comment 1 Karel Zak 2006-08-14 09:23:56 EDT
Please, provide more details.

 - use verbose mode: "mount -v"
 - is there anything useful in dmesg output?
 - try "/sbin/blkid" -- it should be provide info about your devices

Comment 2 VikkiW 2006-08-14 09:31:50 EDT
# mount -v /other
mount: the label /other occurs on both /dev/sdb1 and /dev/dm-23
mount: LABEL=/other duplicate - not mounted

There is nothing useful in dmesg

# blkid
/dev/sda1: UUID="44A8-E88D" TYPE="msdos" 
/dev/sda2: LABEL="/var" UUID="163df5c8-cc74-4a87-9056-11e6221525a5"
SEC_TYPE="ext3" TYPE="ext2" 
/dev/sda3: LABEL="/usr1" UUID="bceb0ee0-48ff-4547-82d8-4f9442faf481"
SEC_TYPE="ext3" TYPE="ext2" 
/dev/sda4: LABEL="/1" UUID="91f283c5-04a1-4820-bea7-6298e444c95c"
SEC_TYPE="ext3" TYPE="ext2" 
/dev/sda5: TYPE="swap" LABEL="SWAP-sda5"
UUID="e5615cbc-9190-4687-9779-dfaae30144db" 
/dev/sda6: TYPE="swap" LABEL="SWAP-sda6"
UUID="569f8f9f-8789-476d-877d-a1fd98d2797b" 
/dev/sda7: TYPE="swap" LABEL="SWAP-sda7"
UUID="597ce5b9-ca46-4d8b-aa4d-9c837658e680" 
/dev/sda8: TYPE="swap" LABEL="SWAP-sda8"
UUID="ef2e8693-adec-402e-a361-ca2ff08c1ffc" 
/dev/sdb1: LABEL="/other" UUID="5023bb05-63ed-4413-913f-20fd44f0bdd8"
SEC_TYPE="ext3" TYPE="ext2" 
/dev/dm-23: LABEL="/other" UUID="5023bb05-63ed-4413-913f-20fd44f0bdd8"
SEC_TYPE="ext3" TYPE="ext2" 

How do I exclude sda1-8 & sdb from device-mapper as this seems to be what is
causing the problem at update 4 ?
Comment 3 Alasdair Kergon 2006-08-14 13:26:46 EDT
Do you know what /dev/dm-23 is?

Run 'dmsetup info -c' and 'dmsetup table'.
[Use dmsetup.static if dmsetup isn't available.]
Comment 4 VikkiW 2006-08-15 02:51:13 EDT
Created attachment 134192 [details]
Output from dmsetup commands
Comment 5 Karel Zak 2006-08-15 04:11:19 EDT
Note, in case you want to use multi-path device you should read the "DUPLICATE
LABELS" section in the RHEL4 mount man page.
Comment 6 VikkiW 2006-08-15 04:42:02 EDT
What is the format for /etc/fstab.order as the man page is unclear ?
Comment 7 Karel Zak 2006-08-15 09:18:39 EDT
Well, man page: 

  You can define priority of devices in file /etc/fstab.order
  as simple list of devices (with full pathname for the devices).
     ^^^^^^^^^^
  The devices listed in this file have greater priority than other
  devices. Devices in configuration file have descending priority.

means:

   /dev/sdb1
   /dev/foo
   /dev/bar

where "sdb1" has greater priority than "foo" and than devices that missing in
/etc/fstab.order.

Note: this solution for duplicate labels is valid for RHEL3 and REHL4 only. The
mount command in RHEL5 will be able to resolve priority automatically.
Comment 8 VikkiW 2006-08-15 09:24:25 EDT
OK. Tried adding the two devices to /etc/fstab.order as :

/dev/sdb1
/dev/dm-23

and I am still getting the error message when trying to mount /dev/sdb1.
Comment 9 Alasdair Kergon 2006-08-15 09:46:27 EDT
The dmsetup output shows that you are running multipath and kpartx.

In these circumstances you need to hide the original (sd) device and mount the
new multipath version instead.

mpath22p1        253  23 L--w    0    1      0 part1-mpath-200000e110082e0d7
mpath22p1: 0 71132893 linear 253:22 34
mpath22: 0 71132960 multipath 0 0 1 1 round-robin 0 1 1 8:16 100 

However, this device only appears to have one path - if that is correct, perhaps
you want to exclude it from the multipath configuration.

Note You need to log in before you can comment on or make changes to this bug.