Bug 202451 - Unknown rule types cause failure with default config.
Unknown rule types cause failure with default config.
Status: CLOSED DUPLICATE of bug 196046
Product: Fedora
Classification: Fedora
Component: snort (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dennis Gilmore
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 11:35 EDT by Dave Jones
Modified: 2015-01-04 17:28 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-02 21:03:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave Jones 2006-08-14 11:35:02 EDT
The default /etc/snort/snort.conf seems to contain a lot of stuff that causes
the daemon not to start up..

snort[7565]: FATAL ERROR: /etc/snort/snort.conf(182) => Unknown rule type:
dynamicpreprocessor 

Is there some module missing perhaps? Or a missing dependancy on the snort rpm?
Comment 1 Dennis Gilmore 2006-08-14 12:58:57 EDT
Dave the dynamic preprocessor is new  and i have yet to have it in the rpm.  
Its high on my list of priorities.  
alot of the other missing items we can not redistribute  due to the license 
that they are released under.  unfortunately as shipped there is no way to 
make the default config just work  and do something useful. 
Comment 2 Dave Jones 2006-09-02 21:03:11 EDT
Might be worth looking to see what the Debian folks did.  When I last setup a
snort box I pretty much only had to set up the IP to listen on, and it 'just
worked'.

I'll dupe this against the earlier snort bug that seems to be the same thing.


*** This bug has been marked as a duplicate of 196046 ***

Note You need to log in before you can comment on or make changes to this bug.