Bug 202460 - ltrace doesn't find all getenv calls
ltrace doesn't find all getenv calls
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ltrace (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Machata
Jay Turner
:
Depends On: 201910
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 12:30 EDT by Petr Machata
Modified: 2015-05-04 21:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-17 10:54:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Machata 2006-08-14 12:30:40 EDT
+++ This bug was initially created as a clone of Bug #201910 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. ltrace -fo/tmp/a psql
2. setenv PGUSER someuser
3. ltrace -fo/tmp/a psql
  
Actual results:
The 'getenv("PGUSER")' call is not recorded (amongst others), but other getenv
calls are.


Expected results:
Ltrace should have recorded all getenv calls.

Additional info:
This is a weird error.

-- Additional comment from pmachata@redhat.com on 2006-08-10 06:09 EST --
Can you try this, please?
$ ltrace psql --help 2>&1 | grep PGUSER
Because this works for me:
getenv("PGUSER")                                 = NULL
getenv("PGUSER")                                 = NULL


-- Additional comment from kernel@pkts.ca on 2006-08-11 12:17 EST --
# ltrace psql --help  |& grep PGUSER
getenv("PGUSER")                                 = NULL
getenv("PGUSER")                                 = NULL
# ltrace -fo/tmp/a psql --help >& /dev/null; grep PGUSER /tmp/a
25900 getenv("PGUSER")                           = NULL
25900 getenv("PGUSER")                           = NULL
# ltrace -fo/tmp/a psql; grep PGUSER /tmp/a
Password: 
psql: FATAL:  password authentication failed for user "root"
# setenv PGUSER db
# setenv PGDATABASE process
# ltrace -fo/tmp/a psql
Password: 
Welcome to psql 8.1.4, the PostgreSQL interactive terminal.
...
process=# \q
# grep PGUSER /tmp/a
# grep PGDATABASE /tmp/a
# 

The psql process is getting the values from the environment, but ltrace isn't
seeing the corresponding getenv() calls except when the command is 'psql --help'.
Comment 2 Jay Turner 2006-08-14 12:58:21 EDT
QE ack if we determine that it is a bug.
Comment 4 RHEL Product and Program Management 2006-08-18 10:41:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 Petr Machata 2006-10-17 10:54:06 EDT
Sorry, completely forgot about this one. It's not a bug, but missing feature of
ltrace, where ltrace doesn't trace calls done from libraries. This feature might
appear in one of future ltreace releases, but no ETA is given.

Note You need to log in before you can comment on or make changes to this bug.