This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 202487 - Add Errata Severity field support to python backend errata Import
Add Errata Severity field support to python backend errata Import
Status: CLOSED CURRENTRELEASE
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Backend (Show other bugs)
rhn415
All Linux
medium Severity medium
: ---
: ---
Assigned To: Pradeep Kilambi
Brandon Perkins
:
Depends On:
Blocks: 201890
  Show dependency treegraph
 
Reported: 2006-08-14 15:17 EDT by Pradeep Kilambi
Modified: 2007-04-18 13:47 EDT (History)
1 user (show)

See Also:
Fixed In Version: RHN415
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-09 15:33:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pradeep Kilambi 2006-08-14 15:17:29 EDT
Description of problem:

The new severity field for errata stuff needs to be understood by the python
xmlrpc calls in the backend. Basically use the rhnErrata and rhnErrataSeverity
to consider severity seperate from synopsis and populate the db taking that into
account.
  
Actual results:
 dont see the severity field in rhnErrata being populated by errata tool.

Expected results:
 should see the severity field in rhnErrata being populated.
Comment 1 Pradeep Kilambi 2006-08-14 16:07:17 EDT
Added the capability where when we try to populate the errata it fills in the
severity_id field based on lookup in rhnErrataSeverity. Basically the changes
are in the importlib such that errata-tool will now send a seperate 'severity'
and we get the id from errataseverity table and insert into
rhnErrata.severity_id field

when we query the database we should see something like:


rhnuser@webdev> select severity_id from rhnErrata where id = 67398

SEVERITY_ID
-----------
          2

1 row selected (0.00 seconds)


Comment 2 Brandon Perkins 2006-10-02 10:40:09 EDT
Verified.  bugzilla_errata.submit_errata() method now sends the 'severity'
key/value pair in the hash to http://scripts.back-webqa.redhat.com/BUGZILLA/. 
Currently, this severity must be sent as lower-case only.  This should be fixed
in another bug.
Comment 3 Beth Nackashi 2006-10-26 14:06:28 EDT
moving from VERIFIED to RELEASE_PENDING since stage push is complete
Comment 4 Brandon Perkins 2006-11-09 15:33:32 EST
closing -- current release.  RHN415 is now in production.

Note You need to log in before you can comment on or make changes to this bug.