Bug 202500 - simultaneous starts confuse rgmanager
Summary: simultaneous starts confuse rgmanager
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-08-14 20:15 UTC by Lon Hohberger
Modified: 2009-04-16 22:35 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-21 15:05:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Lon Hohberger 2006-08-14 20:15:52 UTC
Description of problem: CVS/Head (Development)

Starting two instances of rgmanager simultaneously sometimes ends up with the
higher node overwriting distributed data that the previous node had just written
out, causing a service to be "started" twice on two different nodes.

Comment 1 Lon Hohberger 2006-08-21 15:05:32 UTC
Fixed in CVS.  This happened because nodes would not correctly process the
states of other nodes on boot due to a logic error.

Comment 2 Nate Straz 2007-12-13 17:19:00 UTC
Moving all RHCS ver 5 bugs to RHEL 5 so we can remove RHCS v5 which never existed.


Note You need to log in before you can comment on or make changes to this bug.