Bug 202511 - Aspell-nl has non-FSF compatible license
Summary: Aspell-nl has non-FSF compatible license
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: aspell-nl (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
urgent
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC6Blocker
TreeView+ depends on / blocked
 
Reported: 2006-08-14 21:07 UTC by Tom "spot" Callaway
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 14:39:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patche (645 bytes, patch)
2006-08-16 08:36 UTC, Ivana Varekova
no flags Details | Diff

Description Tom "spot" Callaway 2006-08-14 21:07:10 UTC
This bug is being filed as part of the Fedora FSF licensing audit:

The Copyright in the aspell-nl source tree says:

"All provided material can be used freely. Copying is only allowed if
the package is distributed complete and unchanged. We plan to update
the package on a regular basis. Bug reports and bugfixes are welcomed."

This license doesn't permit modified redistribution, so we should not have
shipped it in the first place. On top of that, Fedora _IS_ patching it, 
so we're in violation of a bad license.

Debian is using an aspell-nl package under GPL with different source, 
I made a package for it here: 
http://www.auroralinux.org/people/spot/review/aspell-nl-0.1e-1.src.rpm
I suggest we replace the existing package in Core with this new one ASAP.

However, it is worth nothing that I do not speak Dutch, and can not vouch for
the validity of the translations in the new package. They should be checked with
our Dutch translators to ensure accuracy.

Comment 1 Tom "spot" Callaway 2006-08-14 21:10:25 UTC
Worth noting, even.

Comment 2 Hans de Goede 2006-08-15 17:57:33 UTC
I'm not a translator but I'm a native Dutch speaker, so I was un happy to see
aspell-nl on the removal list and I'm very happy to so a replacement. Let me
know if you want me todo a quick scan of the new dictionary to make sure it
isn't complete rubish. As it is (supposed to be) a complete dictionary of nearly
all Dutch words, much more then a complete scan won't be possible.


Comment 3 Tom "spot" Callaway 2006-08-15 18:17:40 UTC
Please scan the dictionary! :) I'm not an aspell expert, but it looks as if xfig
may use aspell to do its spell checking, it may be another way you can confirm
the functionality.

Comment 4 Hans de Goede 2006-08-15 18:26:36 UTC
The dictionary looks ok, however it doesn't build on a system where aspell-nl
hasn't already been installed:
+ install -m0755 /usr/src/redhat/SOURCES/ispellaff2myspell wl/
+ cd wl/
+ sed -e '/[_:`^<>()]/d' ./small.wl ./medium.wl ./large.wl ./toponames.wla
./chemistry.wla ./countries.wla ./energy.wla ./jargon.wla ./newwords.wla
./physics.wla ./puzzle.wla
+ tr -d '\267'
+ sort -f
+ uniq
+ tee dutch
+ sed -e '/[- 0-9\.,]/d'
+ ./ispellaff2myspell --charset=latin1 --split=200 --myheader=nl_NL.myheader
dutch.aff
+ /usr/bin/aspell --lang=nl create master ./nl.rws
Error: The language "nl" is not known. This is probably because: the file
"/usr/lib64/aspell-0.60/nl.dat" can not be opened for reading.
error: Bad exit status from /var/tmp/rpm-tmp.87764 (%build)


Comment 5 Tom "spot" Callaway 2006-08-15 18:34:31 UTC
Should be a non-fatal issue. Is this with the old aspell-nl installed or the new
one?

Comment 6 Hans de Goede 2006-08-15 18:45:28 UTC
It is fatal and neither is installed, I think that is the problem, it seems to
need itself installed to build. Chicken <-> Egg?


Comment 7 Ivana Varekova 2006-08-16 08:36:26 UTC
Created attachment 134282 [details]
patche

This problem could be fixed with attached patch.

Comment 8 Hans de Goede 2006-08-16 11:15:54 UTC
Yes that patch fixes it, I've tried aspell with the resulting doc on some old
Dutch texts of mine and it works (and found some spelling errors :)


Comment 10 Ivana Varekova 2006-08-17 14:39:29 UTC
Thanks for your help and for tests. The new version is build now
(aspell-nl-0.1e-1.fc6).


Note You need to log in before you can comment on or make changes to this bug.