This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 202513 - pvremove fails on mac mini re-install
pvremove fails on mac mini re-install
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: lvm2 (Show other bugs)
6
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: LVM and device-mapper development team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 17:11 EDT by Orion Poplawski
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-09 12:44:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda log (36.56 KB, text/plain)
2006-08-14 17:11 EDT, Orion Poplawski
no flags Details
Syslog from install (58.59 KB, text/plain)
2006-08-14 17:11 EDT, Orion Poplawski
no flags Details
mbr and first 200k of each partition (62.41 KB, application/octet-stream)
2006-08-16 16:12 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2006-08-14 17:11:09 EDT
Description of problem:

I'm pretty sure I've seen this before, but can't find the bug report if I made
one.  I'm installing FC6T2 on a ppc mac mini that had FC5 (I think) on it
already.  Selected wipe linux partitions during install.  It's now hung on
"pvremove -ff /dev/hda8".
Comment 1 Orion Poplawski 2006-08-14 17:11:09 EDT
Created attachment 134168 [details]
anaconda log
Comment 2 Orion Poplawski 2006-08-14 17:11:45 EDT
Created attachment 134169 [details]
Syslog from install
Comment 3 Jeremy Katz 2006-08-16 11:06:16 EDT
pvremove should not hang.
Comment 4 Alasdair Kergon 2006-08-16 11:32:28 EDT
Please add -vvvv to the lvm command that is apparently hanging and send me the
output.  Or run it under strace.  Or 'dd' the first 200k of *all* your
partitions at this point so we can attempt to reproduce it elsewhere.

As I've said before, it would be useful if there was an anaconda debug mode that
would capture the -vvvv debug logs from lvm commands.
Comment 5 Orion Poplawski 2006-08-16 16:12:11 EDT
Created attachment 134341 [details]
mbr and first 200k of each partition

Okay, I'm not sure this is (entirely) a lvm problem, though it may have messed
things up earlier (altough think this was a working FC5 system previously).

Looking in the anaconda log:

20:31:00 INFO	 : pv is /dev/hda7 in vg rootvg, size is 25439
20:31:00 INFO	 : pv is /dev/hda8 in vg rootvg, size is 77
20:31:00 INFO	 : vg rootvg, size is 71456, pesize is 32768
20:31:00 INFO	 : vg rootvg, size is 25408, pesize is 32768
20:31:00 ERROR	 : Volume group rootvg using non-existent partition /dev/hda8

and indeed, while the kernel syslog seems to indicate 8 partitions:

<6> hda: [mac] hda1 hda2 hda3 hda4 hda5 hda6 hda7 hda8

parted shows only 7:

Disk /dev/hda: 80.0GB
Sector size (logical/physical): 512B/512B
Partition Table: mac

Number	Start	End	Size	File system  Name     Flags
 1	0.51kB	32.8kB	32.3kB		     primary
 2	32.8kB	1081kB	1049kB	hfs	     primary  boot
 6	1081kB	53.5MB	52.4MB	ext3	     primary
 3	134MB	26.7GB	26.5GB	hfs+	     primary
 4	26.7GB	26.7GB	8913kB	hfs+	     primary
 5	26.7GB	53.4GB	26.7GB		     primary
 7	53.4GB	80.0GB	26.7GB		     primary  lvm

So: 

 - something is incorrectly reporting 8 partitions and saying that rootvg is
using hda8
 - or parted is incorrectly reporting only 7 partitions?  I was able to read
from /dev/hda8 with dd.
 - In any case, pmvremove -ff /dev/hda8 shouldn't hang.  Don't know how to run
under strace or -vvvv during install.  Killed the hung pvremove with kill -9
and it can run okay now.


I've attached the mbr and first 200k of each partition
Comment 6 Orion Poplawski 2006-08-17 16:30:33 EDT
I can't reproduce this with a FC6T2 install on top of an existing FC6T2 install.
 I may try again with FC5...
Comment 7 Alasdair Kergon 2006-08-17 16:44:35 EDT
One thing I noticed while investigating another bug was that pvremove isn't run
with the '-y' argument as it should be.  (Still shouldn't hang of course.)
Comment 8 Matthew Miller 2007-04-06 15:22:18 EDT
Fedora Core 5 and Fedora Core 6 are, as we're sure you've noticed, no longer
test releases. We're cleaning up the bug database and making sure important bug
reports filed against these test releases don't get lost. It would be helpful if
you could test this issue with a released version of Fedora or with the latest
development / test release. Thanks for your help and for your patience.

[This is a bulk message for all open FC5/FC6 test release bugs. I'm adding
myself to the CC list for each bug, so I'll see any comments you make after this
and do my best to make sure every issue gets proper attention.]

Note You need to log in before you can comment on or make changes to this bug.