Bug 202519 - netpbm needs some files removed
netpbm needs some files removed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netpbm (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Jindrich Novy
Ben Levenson
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 17:44 EDT by Tom "spot" Callaway
Modified: 2013-07-02 19:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-14 09:01:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2006-08-14 17:44:02 EDT
This bug is being filed as part of the FSF compatible licensing audit:

The netpbm package is a huge mess of mixed code, some without
licensing or copyright attribution. Start with the excellent copyright analysis
done by Debian, found here:
http://packages.debian.org/changelogs/pool/main/n/netpbm-free/netpbm-free_10.0-8sarge3/netpbm.copyright

In addition, the LZW patent has expired, so ppmtogif is ok. Fedora
Core's netpbm-progs package doesn't have jbigtopnm or pnmtojbig
(although, they are still in the SRPM). The badly licensed hpcdtoppm
isn't in the Fedora package in either source or binary format.
This only leaves the bits that are listed in the Debian copyright as
"Unknown, So Not Distributed". So, lets try to resolve those:
pamchannel: Public Domain (OK)
pamtopnm: Public Domain (OK)
pbmto4425: Author says GPL.
pbmtoln03: Author says Artistic.
pbmtolps: Cannot find current email for author.
pbmtopk/pktopbm/ppmtopjxl: Author says MIT/X11 license.
spottopgm: Cannot find current email for author

I suggest that we ship a modified source version of netpbm with those 
two unlicensed subprograms removed from the source tree (pbmtolps and
spottopgm), as I have been unable to locate the authors. To the best of my
ability, nothing is using pbmtolps or spottopgm.

In addition, we should probably remove the source code for jbigtopnm and
pnmtojbig, even though we're not building the binaries.
Comment 1 Jindrich Novy 2006-08-15 03:09:54 EDT
man pbmtolps says the author is: George Phillips <phillips@cs.ubc.ca>

and for spottopgm: Warren Toomey wkt@csadfa.cs.adfa.oz.au

Will you try to contact them? I have no problem to remove the utilities though.
Comment 2 Tom "spot" Callaway 2006-08-15 10:01:24 EDT
I did. Those email addresses are long since defunct. I was unable to locate
current contact information for either author.
Comment 3 Jindrich Novy 2006-08-15 11:35:22 EDT
Ok, jbig, hpcd, spottopgm, pbmtolps stuff is history now. Thery are removed from
tarballs including their man pages.
Comment 4 Tom "spot" Callaway 2006-09-03 19:58:41 EDT
Found the author of spottopgm, he claims code is GPL. You can readd that to the
tarball and include the binary. :)
Comment 5 Jindrich Novy 2006-09-04 04:24:08 EDT
Ok, hopefully other authors won't change their mind after a next few days ;)

Fixed since 10.34-5.fc6.
Comment 6 Tom "spot" Callaway 2006-09-13 15:02:04 EDT
And... the last author emerges. The license for pbmtolps is LGPL.

Back to where we started (almost). :)
Comment 7 Jindrich Novy 2006-09-14 09:01:44 EDT
Ok, pbmtolps is now added.

Note You need to log in before you can comment on or make changes to this bug.