Bug 202524 - crypto-utils has a bad license and should be removed.
crypto-utils has a bad license and should be removed.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: crypto-utils (Show other bugs)
rawhide
All Linux
urgent Severity urgent
: ---
: ---
Assigned To: Joe Orton
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-08-14 17:58 EDT by Tom "spot" Callaway
Modified: 2013-01-09 23:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-18 06:57:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2006-08-14 17:58:37 EDT
This bug is filed as part of the FSF compatible licensing audit of Fedora:

Crypto-utils contains three pieces of code, with three different licenses:

- librand (AT&T BSD, OK)
- Makerand (GPL or Artistic, OK)
- keyrand (PGP license found here:
ftp://ftp.pgpi.org/pub/pgp/2.x/doc/pgpdoc2.txt, NOT OK)

The keyrand code is under the PGP license, which is pretty restrictive, and not
very open source compatible (it has restrictions on commercial use). Since
keyrand seems to be pretty pivotal for the other bits of crypto-utils, this
package should be removed from the distribution and CVS ASAP.
Comment 1 Jesse Keating 2006-08-17 22:01:32 EDT
I've done some repo queries and I can't find anything that uses this.  Joe, do
you forsee any problems removing this package from the distribution?
Comment 2 Joe Orton 2006-08-18 03:38:23 EDT
The user uses it!  It's the only excuse for a cert generation tool we have.

I built -2.3-1 yesterday which replaces the PGP licensed stuff with a poor man's
keyrand I wrote from scratch, I just need to test this and it can go in.
Comment 3 Joe Orton 2006-08-18 06:57:19 EDT
It works fine, marking closed.

Note You need to log in before you can comment on or make changes to this bug.