Bug 202526 - cdrtools is doing bad things with licensing and should be removed
cdrtools is doing bad things with licensing and should be removed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cdrtools (Show other bugs)
rawhide
All Linux
medium Severity urgent
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks: 203156
  Show dependency treegraph
 
Reported: 2006-08-14 18:05 EDT by Tom "spot" Callaway
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 04:03:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tom "spot" Callaway 2006-08-14 18:05:33 EDT
This bug is filed as part of the FSF compatible licensing audit of Fedora:

Cdrtools is doing bad things with licensing. The upstream author is relicensing
bits of cdrtools as CDDL, when previously, this code was GPL. Since the CDDL and
GPL are incompatible, this mixture of the two licenses is not permissable, and
we should not be shipping this code.

See: http://lwn.net/Articles/195167/

Please note that this is not just the Build tools being relicensed as CDDL, the
upstream author is actually relicensing code as CDDL.

To paraphrase Mr. Corbet, since "... cdrtools cannot be distributed in it
current form, they (distributors) will have no alternative to ceasing
distribution - and that means coming up with a replacement."

Proposed replacement: http://www.arklinux.org/projects/dvdrtools
Comment 3 Hans de Goede 2006-08-15 14:00:22 EDT
AFAIK, we could shipping a somewhat older version right? That would atleast give
people something working in most cases. I think trying to find a suitable
replacement before FC-6 is a bad idea.
Comment 4 Tom "spot" Callaway 2006-08-15 14:09:30 EDT
dvdrtools is the fork from the last version before license tainting.

While the timing here is poor, we need to decide if we are willing to ship FC-6
with a piece of code that is illegal.
Comment 5 Hans de Goede 2006-08-15 14:10:46 EDT
(In reply to comment #4)
> dvdrtools is the fork from the last version before license tainting.
> 
AH, good, I forgot it was a fork.

> While the timing here is poor, we need to decide if we are willing to ship FC-6
> with a piece of code that is illegal.
>

I'm not in the positions to make such decissions but I would say NO!
Comment 6 Tom "spot" Callaway 2006-08-15 14:16:03 EDT
(In reply to comment #5)

> > While the timing here is poor, we need to decide if we are willing to ship FC-6
> > with a piece of code that is illegal.
> >
> 
> I'm not in the positions to make such decissions but I would say NO!

Neither am I, but I would also say this is a blocker issue for FC-6.
Comment 8 Bill Nottingham 2006-08-15 17:33:14 EDT
Can we just go back to the old all-GPL version?
Comment 9 Harald Hoyer 2006-08-16 02:06:40 EDT
We can go back to FC-4's cdrtools-2.0, but this version will cause many problems.
Oh my... I was so happy the current version works...
Comment 12 Hans de Goede 2006-08-16 05:56:14 EDT
Maybe someone could do a diff between the latest GPL and the current upstream
release and then if there are not too much changes describe the changes which
are clearly fixes in plain english (iow not code) and then someone else who
didn't look at the diff can reimplement them. Or would that legally still be too
dodgy?

Comment 13 Harald Hoyer 2006-08-16 06:11:28 EDT
Too much changes... e.g. DVD support. 
A real fork of the project or complete rewrite would be the best... 
Comment 14 Hans de Goede 2006-08-16 06:31:35 EDT
Isn't dvdrtools just that (a fork), surely dvdrtools should be better then a
pretty old version of cdrtools without dvd support?
Comment 15 Harald Hoyer 2006-08-16 06:44:08 EDT
For DVD support, I took the patches from http://crashrecovery.org/oss-dvd.html
dvdrecord is much older than 2.01
Comment 16 Hans de Goede 2006-08-16 07:08:31 EDT
Ok, I'll shut up now. Let me know if there is anything usefull I can do to help.

p.s. Tom, I think its great that FC is being cleaned of this, painfull, but
great! Let me know if I can be of assistance. (I'm quite good in C).

Comment 17 Harald Hoyer 2006-08-16 08:25:18 EDT
you could rewrite cdrecord from scratch :) maybe by taking growisofs :)
Comment 18 Daniel Riek 2006-08-17 10:07:32 EDT
A problem is that even with older versions there are some irritating limits to
the license:

> This software is under GPL with the following limitations:
>
>
> -       You may not modify certain copyright messages in cdrecord.c
>
>        See cdrecord.c for further information.
>
>
>-       You may (with a few exceptions) not modify the location of the
>        configuration file /etc/default/cdrecord.
>
>        See defaults.c for further information.

Long-term libburn seems to be a promising project.
Comment 19 Bill Nottingham 2006-08-17 10:21:02 EDT
That's nonsensical, you can't impose additional restrictions on top of GPL.
Comment 20 Matthew Miller 2006-08-17 10:31:02 EDT
Sure, you can create a license that is "GPL, but slightly different, including
these restrictions" -- but that license won't be even slightly GPL-compatible,
and you certainly can't *add* those restrictions to existing GPL'd code.
Comment 21 Matthew Miller 2006-08-18 13:38:14 EDT
What's secret bug #203156?
Comment 22 Bill Nottingham 2006-08-18 13:45:49 EDT
Matt: internal rhel5 tracking stuff.

Note You need to log in before you can comment on or make changes to this bug.