Bug 202536 - pirut crashes when switching from List view to Search view
pirut crashes when switching from List view to Search view
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-14 19:19 EDT by Paul W. Frields
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-14 20:44:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul W. Frields 2006-08-14 19:19:55 EDT
Description of problem:
Rawhide, current as of ~1200 UTC, 2006-08-14.  pirut crashes when switching from
the List view to the Search view.

Version-Release number of selected component (if applicable):
1.1.8-1

How reproducible:
Every time.

Steps to Reproduce:
1. Run pirut.
2. Select List view. Wait for parser to finish normally.
3. Select Search view.
  
Actual results:
Kerplooie.

Expected results:
A proper list view.

Additional info:
Bug reporter generates the following output.  I am just learning Python so I
restarted once from a terminal and tried "Debug" just to see if I could learn
anything -- to no avail of course. :-)  But I *do* know (or *think* I know) that
the self.xml.get_widget("packageListTree") is probably expected to return a
gtk.Widget, right?  Maybe this is an incorrect widget label?  Aww, listen to me
jawin' like I know somethin'.  What a swelled-head.  Pay me no mind, here's the
report:

- - - - -
Component: Software Manager
Summary: TB969e4b0d PackageList.py:137:grab_focus:AttributeError: 'NoneType'
object has no attribute 'grab_focus'

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 230, in _showList
    plist.grab_focus()
  File "/usr/lib/python2.4/site-packages/pirut/PackageList.py", line 137, in
grab_focus
    self.xml.get_widget("packageListTree").grab_focus()
AttributeError: 'NoneType' object has no attribute 'grab_focus'

Local variables in innermost frame:
self: <PirutPackageList object (pirut+PackageList+PirutPackageList) at 0xa15d5f4>
- - - - -
Comment 1 Jeremy Katz 2006-08-14 20:44:32 EDT
I can't reproduce this, but committed something which should hopefully avoid it
being a problem

Note You need to log in before you can comment on or make changes to this bug.