Bug 202566 - gnome-screensaver no longer picks up first characters of password
gnome-screensaver no longer picks up first characters of password
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 01:02 EDT by David Baron
Modified: 2008-03-18 17:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 14:41:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Baron 2006-08-15 01:02:41 EDT
Description of problem:  When the screensaver was active, it used to be possible
to begin typing my password before the password dialog was shown.  Then once it
was shown, all the characters I had typed would be in the dialog, and I could
hit enter and the correct password would be recorded.  Now the first few
characters typed are dropped.

This is a regression with the most recent update pushed to FC5 updates.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.14.3-1.fc5.i386.rpm

How reproducible:  Always (assuming I type fast)

Steps to Reproduce:
1. lock screen
2. type password (making sure to hit the first few characters quickly)
3. hit enter once you see the dialog
  
Actual results:
2. the number of dots in the password prompt is less than the number of
characters typed
3. access is denied, and I am required to type my password again

Expected results:
2. the number of dots in the prompt is the same as the number of characters typed
3. the screen is unlocked

Additional info:  I tested that the bug goes away when I downgrade to
gnome-screensaver-2.14.2-1.fc5.1.i386.rpm , kill gnome-screensaver, and restart
it, and that the bug then comes back when I upgrade again to
gnome-screensaver-2.14.3-1.fc5.i386.rpm, kill gnome-screensaver, and restart it.

It also appears that the password dialog now takes longer to appear than it used
to; this delay may well be related to the problem, although I'd think that all
keystrokes should be captured, no matter what's going on.
Comment 1 jmccann 2006-08-15 07:59:27 EDT
Yes this regression was caused by the fix for GNOME bug #339330.  The fix for
the regression just missed the 2.14.3 release but is in upstream CVS.  Is it
possible for you to test that it fixes your problem?  Thanks.

2006-08-03  William Jon McCann  <mccann@jhu.edu>

        * src/gs-window-x11.c (gs_window_real_key_press_event)
        (queue_key_event):
        Fix problem where we were only queuing one key event.
        Also add a paranoid limit on the number of queued keys.
Comment 2 David Baron 2006-10-31 12:03:42 EST
This worked OK in the gnome-screensaver that was shipped in FC6, but regressed
again in the update that was pushed yesterday to FC6 updates:
Oct 30 14:49:21 Updated: gnome-screensaver.i386 2.16.1-2.fc6
Comment 3 Ray Strode [halfline] 2008-03-18 14:41:08 EDT
Hi,

We no longer support Fedora Core 6 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)
Comment 4 David Baron 2008-03-18 17:00:18 EDT
Yeah, this has been fixed for a while.

Note You need to log in before you can comment on or make changes to this bug.