Bug 2025697 - Update Azure Machine Spec API to accept Marketplace Images
Summary: Update Azure Machine Spec API to accept Marketplace Images
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Cloud Compute
Version: 4.9
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: 4.9.z
Assignee: Patrick Dillon
QA Contact: sunzhaohua
URL:
Whiteboard:
: 2021513 (view as bug list)
Depends On: 2023434
Blocks: 2027896
TreeView+ depends on / blocked
 
Reported: 2021-11-22 18:45 UTC by Patrick Dillon
Modified: 2022-01-06 16:06 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 2027896 (view as bug list)
Environment:
Last Closed: 2021-12-13 12:06:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift cluster-api-provider-azure pull 243 0 None open Bug 2025697: API: Update Machine Provider Spec Image Type 2021-11-30 09:07:13 UTC
Github openshift machine-api-operator pull 965 0 None open Bug 2025697: [release-4.9]: Bump CAPZ API 2021-12-02 02:15:58 UTC
Red Hat Product Errata RHBA-2021:5003 0 None None None 2021-12-13 12:06:53 UTC

Description Patrick Dillon 2021-11-22 18:45:56 UTC
This bug was initially created as a copy of Bug #2023434

I am copying this bug because: backporting compatibility



The AzureMachineProviderSpec has limited support for specifying details about an Azure Marketplace or Shared Compute Gallery image. Now that we will be adding OpenShift CoreOS images to the marketplace, we need to have further support so that we can specify purchase plans when required AND for backward compatibility NOT supply purchase plans when they are not needed.

Comment 4 sunzhaohua 2021-12-06 08:22:08 UTC
Verified
cluster version: 4.9.0-0.nightly-2021-12-03-233811
1.After generating manifests, modify the image spec in worker machineset as
            image:
              offer: ocp-rhcos-worker
              publisher: redhat-rhel
              resourceID: ''
              sku: ocp-4-free
              type: MarketplaceWithPlan
              version: 4.9.2021111600
Installation finished successfully
2.Post installtion create machineset with above image, machine works well.
3.Create a cluster with WMCO, windows node works well.
4.Run functional Regression and upgrade regression testing, no new issues were found.

Comment 7 errata-xmlrpc 2021-12-13 12:06:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:5003

Comment 8 Patrick Dillon 2022-01-06 16:06:52 UTC
*** Bug 2021513 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.