Bug 202573 - Icons cannot be shown for new task if category is Birthday/International/Time & Expenses
Icons cannot be shown for new task if category is Birthday/International/Time...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 04:45 EDT by Xiaohong Wang
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-02 11:01:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (44.09 KB, image/png)
2006-08-15 04:45 EDT, Xiaohong Wang
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 351930 None None None Never

  None (edit)
Description Xiaohong Wang 2006-08-15 04:45:12 EDT
Description of problem:


Version-Release number of selected component (if applicable):
evolution-2.7.91-2

How reproducible:
always

Steps to Reproduce:
1. Launch Tasks-Evolution 
2. Create a new task and set "Categories" to be Birthday/International/Time &
Expenses
3. Save the task and check it in task preview window

  
Actual results:
Icons cannot be shown, pls see attached screenshot

Expected results:


Additional info:
Comment 1 Xiaohong Wang 2006-08-15 04:45:13 EDT
Created attachment 134198 [details]
screenshot
Comment 2 Matthew Barnes 2006-08-24 18:13:47 EDT
Changing component to 'evolution-data-server'.
See my analysis in the upstream bug report.

An ugly workaround for this follows:

1) Start Configuration Editor
2) Navigate to /apps/evolution/general/category_master_list
3) Right click on category_master_list, and select Edit Key
4) This is a very long XML string, and each category has a icon attribute that
   gives a path to the image file.  Look for evolution-data-server-1.x in each
   path.  The 'x' is probably older than what you're using now.

E-D-S needs to be able to keep these paths up-to-date without manual
intervention.  One approach may be to abstract the path to the icon file in the
GConf string and have E-D-S expand it at runtime.

For example, the GConf string

    "$(eds-pixmap-dir)/category_holiday_16.png"

would be expanded at runtime to

    "/usr/share/pixmaps/evolution-data-server-1.6/category_holiday_16.png"

for evolution-data-server 1.5/1.6, and to

    "/usr/share/pixmaps/evolution-data-server-1.8/category_holiday_18.png"

for evolution-data-server 1.7/1.8.
Comment 3 Matthew Barnes 2007-01-02 11:01:46 EST
Closing as UPSTREAM since I forwarded this upstream awhile ago.  I believe this
has been at least partially fixed in subsequent evolution-data-server releases,
but I will continue to track the remaining issues there.  Please refer to [1]
for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=351930

Note You need to log in before you can comment on or make changes to this bug.