Bug 202588 - Unable to install RPMs in rescue mode
Unable to install RPMs in rescue mode
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 07:59 EDT by Adam Huffman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-15 13:41:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2006-08-15 07:59:34 EDT
Description of problem:
When attempting to get around a kernel problem, I tried booting to rescue mode
and installing an alternative kernel.  The RPM installation did not succeed.

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. rpm -ivh kernel-blah.rpm
2.
3.
  
Actual results:
Lots of errors about /mnt/sysimage/var/lib/rpm/Basenames, even though that file
was present.

Expected results:
Kernel RPM should be installed into the chroot system.

Additional info:
Comment 1 Paul Nasrat 2006-08-15 10:38:33 EDT
Your invocation looks incorrect.

Either chroot /mnt/sysimage then install using rpm -ivh or outside chroot rpm
--root /mnt/sysimage -ivh /path/to/kernel.

Comment 2 Adam Huffman 2006-08-15 11:57:36 EDT
I did the former (chroot first then rom -ivh) - that's what didn't work.
Comment 3 Paul Nasrat 2006-08-15 13:41:38 EDT
I've just used fc6t2 pxelinux images to do the following:

1) cp /mnt/source/<RAWHIDE-KERNEL>.rpm /mnt/sysimage/root
2) chroot /mnt/sysimage
3) rpm -ivh /root/<RAWHIDE-KERNEL>.rpm

Worked fine
rpm -q kernel
rpm -e <OLD KERNEL>

ctrl-D to exit chroot

1) rpm -ivh --oldpackage --root /mnt/sysimage \
/mnt/source/Fedora/RPMS/<FC6T2-KERNEL>.rpm

Worked fine for me.  If you can reproduce please reopen with full steps and
fully transcribed error messages.

Note You need to log in before you can comment on or make changes to this bug.