Bug 202596 - mkinitrd not loading raid456 module for raid5 devices
mkinitrd not loading raid456 module for raid5 devices
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
David Lawrence
: Reopened
Depends On:
Blocks: FC6Blocker 202996
  Show dependency treegraph
 
Reported: 2006-08-15 09:15 EDT by Clyde E. Kunkel
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-17 14:33:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mkinitrd -f -v without specifying any modules to load (3.60 KB, text/plain)
2006-08-15 09:15 EDT, Clyde E. Kunkel
no flags Details
mkinitrd -f -v --with=raid456 (4.13 KB, text/plain)
2006-08-15 09:16 EDT, Clyde E. Kunkel
no flags Details

  None (edit)
Description Clyde E. Kunkel 2006-08-15 09:15:16 EDT
Description of problem:
mkinitrd detecting need for raid5 personality, but does not load raid456 module
and thus the resulting initrd fails with kernel panic, not syncing since /
cannot be found.

Version-Release number of selected component (if applicable):
mkinitrd-5.1.6-1

How reproducible:
Every time.

Steps to Reproduce:
1. yum update
2. reboot
3. kernel panic.  Msg that raid5 personality not loaded is seen during initrd boot
  
Actual results:
kernel panic since / can't be found

Expected results:
Normal boot

Additional info:

This system has the root filesystem on LVM over software raid5.  The problem has
been around awhile, but only discovered when updating system from rawhide after
not updating for over two months.  

Running mkinitrd -f -v without specifying raid456 module results is same bad img
file as when using yum.  File attached showing results.  Note that need for
raid5 is detected, but module raid456 is not loaded.  Running mkinitrd -f -v
--with=raid456 results in good img file that boots properly.  File attached
showing results.  Previous version of mkinitrd also failed.  Did not go back
farther to see where the problem started.
Comment 1 Clyde E. Kunkel 2006-08-15 09:15:16 EDT
Created attachment 134209 [details]
mkinitrd -f -v without specifying any modules to load
Comment 2 Clyde E. Kunkel 2006-08-15 09:16:32 EDT
Created attachment 134210 [details]
mkinitrd -f -v --with=raid456
Comment 4 Bill Nottingham 2006-08-15 11:53:53 EDT
The patch in bug 202559 fixes this as a side effect.
Comment 5 Jay Turner 2006-08-17 21:19:04 EDT
What in the world happened with this bug.  It was a RHEL5 bug with a beta
blocker status requested, but now it's a FC bug which has been closed out.  Is
this still an issue with RHEL5?  More importantly, is this an issue which needs
to be resolved for beta?  If so, we really need a RHEL version of the bug to
track things.
Comment 6 Jay Turner 2006-08-17 21:20:55 EDT
OK, ignore comment 5.  I see this was cloned to another bug for RHEL.
Comment 7 Clyde E. Kunkel 2006-10-17 17:21:06 EDT
I am seeing this bug for mkinitrd-5.0.32-2 when updating FC5 to kernel
2.6.18-1.2200.fc5smp.  Reruning mkinitrd under an older FC5 kernel and using
--with=raid456 solves the problem.

Should this bug be reopened or a new bug entered?
Comment 8 Bill Nottingham 2006-10-17 17:25:23 EDT
Open a new one, please.
Comment 9 Clyde E. Kunkel 2006-10-17 19:27:11 EDT
found one already opened:  bug 211030.

Note You need to log in before you can comment on or make changes to this bug.