Bug 202600 - Evolution get crashed after selecting "Save As Vcard" for a LDAP address book
Evolution get crashed after selecting "Save As Vcard" for a LDAP address book
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Milan Crha
: Desktop
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 09:35 EDT by Xiaohong Wang
Modified: 2008-03-14 16:00 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 16:00:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaohong Wang 2006-08-15 09:35:13 EDT
Description of problem:


Version-Release number of selected component (if applicable):
evolution-2.7.91-2

How reproducible:
always

Steps to Reproduce:
1. Launch Contacts-Evolution 
2. Add a remote LDAP address book (New->Address book, name it Redhat, server
ldap.devel.redhat.com, port is the default (389), never use secure connection,
anonymous login, click "Find possible search bases" and select
"dc=redhat,dc=com", Search scope Sub).
3. Right click "Redhat" LDAP address book and select "Save As Vcard"

  
Actual results:
Evolution get crashed

Expected results:


Additional info:
Comment 1 Matthew Barnes 2006-09-01 14:14:41 EDT
Hmm, the new address book does not show up for me after I click OK in the "New
Address Book" dialog.  I've tried setting this up in the past and had the same
problem.

Unable to reproduce this yet since I can't get to step 3.
Comment 2 Michal Babej 2006-11-08 09:01:57 EST
I was able to go through all steps on evolution-2.8.1.1-3.fc6, no crash
appeared. The whole list gets a little long to download, while evo is freezed
and doesnt repaint :-) but i was able to save the vcf, no crash.
Comment 3 Christopher Aillon 2007-04-17 15:27:14 EDT
matt, can you take another look at this? 
Comment 4 Milan Crha 2007-05-28 09:35:09 EDT
There is only one thing which changed, in the search bases of the LDAP server,
there is other name, "dc=devel,dc=redhat,dc=com". But it didn't matter.

I tested this on three FC versions:
FC5 evolution-2.6.0-1 evolution-data-server-1.5.92-1
FC6 evolution-2.8.3-2.fc6 evolution-data-server-1.8.3-6.fc6
FC7 svn trunk (evolution 2.11.2 evolution-data-server 1.11.2)

and it never crashes, it only freeze for about 2 minutes (for me), as Michal said.
Comment 5 Matthew Barnes 2008-03-14 16:00:32 EDT
Sounds like this can be closed.  Feel free to reopen if the same crash occurs on
Fedora 8 or later.

Note You need to log in before you can comment on or make changes to this bug.