Bug 20262 - up2date does not terminate after upgrading a package
up2date does not terminate after upgrading a package
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-02 19:06 EST by j. alan eldridge
Modified: 2007-04-18 12:29 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-28 11:27:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description j. alan eldridge 2000-11-02 19:06:56 EST
[root@wozzle /root]# rpm -q up2date
up2date-2.0.6-1
[root@wozzle /root]# 


run up2date. upgrade one or more packages. up2date retrieves correctly,
performs the rpm upgrade, then:

[root@wozzle /root]# cat typescript 
Script started on Thu Nov  2 18:49:09 2000
[root@wozzle /root]# up2date
/var/spool/up2date/gnorpm-0.95.1-5.i386.rpm: md5 gpg OK
Traceback (innermost last):
  File "/usr/share/rhn/up2date/gui.py", line 475, in doInstallation
    up2date.installPackages(self.selectedPkgList, self.rpmCallback)
  File "/usr/share/rhn/up2date/up2date.py", line 1040, in installPackages
    rc = ts.run(0, 0, rpmCallback, cfg.readEntry("storageDir"))
  File "/usr/share/rhn/up2date/gui.py", line 434, in rpmCallback
    up2date.remoteAddPackage((name, version, release, epoch))
  File "/usr/share/rhn/up2date/up2date.py", line 615, in remoteAddPackage
    raise CommunicationError(e.errmsg)
up2date.CommunicationError: Error communicating with server.  The message
was:
Internal Server Error
[***at this point i did a killall up2date***]
Terminated
[root@wozzle /root]# exit

Script done on Thu Nov  2 18:56:07 2000
[root@wozzle /root]# 

This behavior occurs 100% of the times that up2date is used to upgrade a
package. it has *never* terminated correctly unless no packages were
upgraded.

This behavior occurs with the original up2date rpm shipped with 7.0, as
well as the one currently installed.

see machine configuration in rhn: wozzle.geeksrus.net.
Comment 1 Preston Brown 2000-11-28 11:27:51 EST
this was in all likelihood a transient server side error.  Has the problem
persisted?
Comment 2 Preston Brown 2000-12-27 16:50:53 EST
closed due to lack of additional feedback, and a feeling on my part that all 
the server side errors that caused this are resolved.

Note You need to log in before you can comment on or make changes to this bug.