Bug 202657 - esc error dialogs aren't helpful
esc error dialogs aren't helpful
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: esc (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jack Magne
Depends On:
Blocks: 181509
  Show dependency treegraph
Reported: 2006-08-15 14:56 EDT by Ray Strode [halfline]
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-11-13 08:06:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Ray Strode [halfline] 2006-08-15 14:56:42 EDT
Today I tried to set up one of our QA guys with a smart card.  He wanted to try
out the new technology and was willing to work through problems and file bug

I ran into a lot of issues that ended up being because the cseng server isn't
suitable for use with rawhide.  Eventually we figured things out, but all
throughout the process we were greeted with dialogs that gave error codes.

Error code 28 was the big one, but we also got error code 14 when we tried to
use his kerberos username and password with the air server.  

Since the error codes have no meaning to the user, we shouldn't show them.  We
should give a specific message about what happened, when possible, and when not
possible give a generic message and tell the user to contact their cert server

We could still put the error codes in a log file of course, it if it will help
in isolating bugs in the code.
Comment 1 Bob Lord 2006-09-08 17:51:27 EDT
Is this bug report still valid given the changes that have been made recently? 

If so, should we change the title to "ESC should show human readable errors
instead of numeric error codes" ?

Comment 2 Orla Hegarty 2006-09-14 19:14:52 EDT
Per todays bug council it was decided that this bug was fixed. Marking modified.
If this bug isn't fixed please set it back to assigned otherwise I will re-test.
Comment 3 Orla Hegarty 2006-10-13 14:36:48 EDT
I triggered a bunch of errors via ESC which came from the deployed TPS / CA The
error numbers are still presented but there are human readable messages
underneath. At least for the error conditions I was able to trigger. 

Marking this bug VERIFIED fixed against candidate build RHEL5-Client-20061006.2
If someone comes across an error which does not also have accompanying human
readable text please feel free to reopen this bug 
Comment 4 Jay Turner 2006-11-13 08:06:38 EST
Closing out as resolved with the 20061111.0 trees.

Note You need to log in before you can comment on or make changes to this bug.