Bug 202663 - installer won't load stage2 on NFS install
installer won't load stage2 on NFS install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: squashfs-tools (Show other bugs)
rawhide
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
: 202806 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 15:32 EDT by G.Wolfe Woodbury
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 10:53:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
mksquashfs patch (1.24 KB, patch)
2006-08-17 10:31 EDT, Chris Lumens
no flags Details | Diff

  None (edit)
Description G.Wolfe Woodbury 2006-08-15 15:32:21 EDT
Description of problem:
NFS install of rawhide 2006-08-15 won't load stage2 or run anaconda


Version-Release number of selected component (if applicable):


How reproducible:
always


Steps to Reproduce:
1. boot.iso or 2006-08-15
2. hit return
3. configure NFS install from local mirror
  
Actual results:
system hangs attempting to load stage2 from NFS server (forever >20mins)


Expected results:
load of stage2 and anaconda install


Additional info:

work1 testbed machine - Celeron(Coppermine)@600MHz  256 MB RAM   VIA IDE chipset
video1: Trident Cyberblade/i1    video2: ATI (Mach64)
160GB IDE disk      RTL8xxx NIC     etc...
Comment 1 Chris Lumens 2006-08-16 10:32:10 EDT
This appears to be a bug in making squashfs filesystems, as the machine is
locking when anaconda goes to mount stage2.img.

According to Phillip Lougher:

> The Mksquashfs bug is a 'corner case bug' that occurs when the number
> of fragments in the filesystem is a multiple of 512 bytes.  Your
> 'rawhide' builds may be hitting this magic number every couple of days
> causing the intermittent bug.
> 
> There is only one way to check this which is to analyse the Squashfs
> filesystem on the rawhide builds that crash or hang.  The attached
> program will check a Squashfs filesystem and print either 'BUGGED
> Squashfs filesystem' or 'OK Squashfs filesystem'.

I have run his test program against our stage2.img and it does in fact show that
the image is bad.
Comment 2 Jeremy Katz 2006-08-16 10:53:55 EDT
Applied the patch from the upstream squashfs archives and built squashfs-tools-3.0-2
Comment 3 Jeremy Katz 2006-08-16 13:28:38 EDT
*** Bug 202806 has been marked as a duplicate of this bug. ***
Comment 4 Chris Lumens 2006-08-17 10:31:46 EDT
Created attachment 134385 [details]
mksquashfs patch
Comment 5 Chris Lumens 2006-08-17 10:33:26 EDT
Today's rawhide works for me.  However just for future reference, I am attaching
a slightly different version of the mksquashfs patch as provided to me by
Phillip.  Please check and make sure whether or not we need the differences in
what went into 3.0-2.

Note You need to log in before you can comment on or make changes to this bug.