Bug 2026729 - python-podman-api and python3-podman cannot be installed together due to files conflict
Summary: python-podman-api and python3-podman cannot be installed together due to file...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: python-podman-api
Version: 8.5
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Jindrich Novy
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-11-25 16:26 UTC by Jan Stourac
Modified: 2022-09-15 12:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-09-09 08:11:26 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Issue Tracker RHELPLAN-103978 0 None None None 2021-11-25 16:26:56 UTC

Description Jan Stourac 2021-11-25 16:26:32 UTC
Description of a problem:

Cannot install both `python-podman-api` package together with `python3-podman` package due to the files conflicts.

Platform RHEL8.5, tested architecture x86_64, but may be present on others too.


Version-Release number of selected component (if applicable):

python-podman-api version is: 1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526
python3-podman version is: 3.2.0-2.module+el8.5.0+12582+56d94c81


How reproducible:

always


Steps to Reproduce:
1. install a brand new RHEL8.5
2. subscribe against RHEL appstream repositories 
3. sudo dnf install -y python-podman-api python3-podman


Actual results:

Error: Transaction test error:
  file /usr/lib/python3.6/site-packages/podman/__init__.py conflicts between attempted installs of python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch and python3-podman-3.2.0-2.module+el8.5.0+12582+56d94c81.noarch
  file /usr/lib/python3.6/site-packages/podman/__pycache__/__init__.cpython-36.opt-1.pyc conflicts between attempted installs of python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch and python3-podman-3.2.0-2.module+el8.5.0+12582+56d94c81.noarch
  file /usr/lib/python3.6/site-packages/podman/__pycache__/__init__.cpython-36.pyc conflicts between attempted installs of python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch and python3-podman-3.2.0-2.module+el8.5.0+12582+56d94c81.noarch
  file /usr/lib/python3.6/site-packages/podman/__pycache__/client.cpython-36.opt-1.pyc conflicts between attempted installs of python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch and python3-podman-3.2.0-2.module+el8.5.0+12582+56d94c81.noarch
  file /usr/lib/python3.6/site-packages/podman/__pycache__/client.cpython-36.pyc conflicts between attempted installs of python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch and python3-podman-3.2.0-2.module+el8.5.0+12582+56d94c81.noarch
  file /usr/lib/python3.6/site-packages/podman/client.py conflicts between attempted installs of python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch and python3-podman-3.2.0-2.module+el8.5.0+12582+56d94c81.noarch


Expected results:

package installation succeeds OR metadata in packages are set so that these packages have `conflicts` or `obsoletes` metadata set properly

Additional info:

Truth is that I can see in pulp repo that there are two newer releases of python-podman-api but for some reason I don't see these on my machine?

python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.4.0+10193+e90fd8eb.noarch.rpm	2021-04-05 16:46	43K	RPM package file
python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.5.0+10223+f7559c42.noarch.rpm	2021-09-29 10:00	43K	RPM package file

Not sure whether this is related to this issue somehow https://bugzilla.redhat.com/show_bug.cgi?id=2015824.


Also, I'm not completely sure that my expectations are 100% correct. Maybe I'm missing some important bit here. But I would expect that conflicting packages shall have this info in their metadata. Truth is that result of the operation is same but it feels a bit more correct way :)

Comment 2 mertensb.mazda 2022-02-03 09:38:09 UTC
I've run into the same problem while updating the container tools group:
~~~
$ sudo yum install @container-tools
Updating Subscription Management repositories.
Last metadata expiration check: 3:39:53 ago on Thu Feb  3 06:50:50 2022.
Dependencies resolved.
================================================================================================================================================================================================= Package                                        Architecture              Version                                                      Repository                                           Size
=================================================================================================================================================================================================Upgrading:
 buildah                                        x86_64                    1:1.23.1-2.module+el8.5.0+13436+9c05b4ba                     rhel-8-for-x86_64-appstream-rpms                    7.9 M
 cockpit-podman                                 noarch                    39-1.module+el8.5.0+13754+92ec836b                           rhel-8-for-x86_64-appstream-rpms                    483 k
 conmon                                         x86_64                    2:2.0.32-1.module+el8.5.0+13852+150547f7                     rhel-8-for-x86_64-appstream-rpms                     55 k
 container-selinux                              noarch                    2:2.173.0-1.module+el8.5.0+13852+150547f7                    rhel-8-for-x86_64-appstream-rpms                     57 k
 containernetworking-plugins                    x86_64                    1.0.1-1.module+el8.5.0+13436+9c05b4ba                        rhel-8-for-x86_64-appstream-rpms                     19 M
 containers-common                              noarch                    2:1-8.module+el8.5.0+13954+1b78b731                          rhel-8-for-x86_64-appstream-rpms                     89 k
 crun                                           x86_64                    1.4.1-1.module+el8.5.0+13882+8ad012a9                        rhel-8-for-x86_64-appstream-rpms                    206 k
 fuse-overlayfs                                 x86_64                    1.8-1.module+el8.5.0+13754+92ec836b                          rhel-8-for-x86_64-appstream-rpms                     73 k
 podman                                         x86_64                    1:3.4.2-9.module+el8.5.0+13852+150547f7                      rhel-8-for-x86_64-appstream-rpms                     12 M
 podman-catatonit                               x86_64                    1:3.4.2-9.module+el8.5.0+13852+150547f7                      rhel-8-for-x86_64-appstream-rpms                    345 k
 runc                                           x86_64                    1.0.3-1.module+el8.5.0+13556+7f055e70                        rhel-8-for-x86_64-appstream-rpms                    3.1 M
 skopeo                                         x86_64                    2:1.5.2-1.module+el8.5.0+13517+4134e2e1                      rhel-8-for-x86_64-appstream-rpms                    6.8 M
 udica                                          noarch                    0.2.6-1.module+el8.5.0+13436+9c05b4ba                        rhel-8-for-x86_64-appstream-rpms                     48 k
Installing group/module packages:
 python3-podman                                 noarch                    3.2.1-1.module+el8.5.0+13436+9c05b4ba                        rhel-8-for-x86_64-appstream-rpms                    149 k
Installing dependencies:
 python3-pytoml                                 noarch                    0.1.14-5.git7dea353.el8                                      rhel-8-for-x86_64-appstream-rpms                     25 k
 python3-pyxdg                                  noarch                    0.25-16.el8                                                  rhel-8-for-x86_64-appstream-rpms                     94 k

Transaction Summary
=================================================================================================================================================================================================Install   3 Packages
Upgrade  13 Packages

Total size: 51 M
...

Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'yum clean packages'.
Error: Transaction test error:
  file /usr/lib/python3.6/site-packages/podman/__init__.py from install of python3-podman-3.2.1-1.module+el8.5.0+13436+9c05b4ba.noarch conflicts with file from package python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch
  file /usr/lib/python3.6/site-packages/podman/__pycache__/__init__.cpython-36.opt-1.pyc from install of python3-podman-3.2.1-1.module+el8.5.0+13436+9c05b4ba.noarch conflicts with file from package python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch
  file /usr/lib/python3.6/site-packages/podman/__pycache__/__init__.cpython-36.pyc from install of python3-podman-3.2.1-1.module+el8.5.0+13436+9c05b4ba.noarch conflicts with file from package python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch
  file /usr/lib/python3.6/site-packages/podman/__pycache__/client.cpython-36.opt-1.pyc from install of python3-podman-3.2.1-1.module+el8.5.0+13436+9c05b4ba.noarch conflicts with file from package python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch
  file /usr/lib/python3.6/site-packages/podman/__pycache__/client.cpython-36.pyc from install of python3-podman-3.2.1-1.module+el8.5.0+13436+9c05b4ba.noarch conflicts with file from package python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch
  file /usr/lib/python3.6/site-packages/podman/client.py from install of python3-podman-3.2.1-1.module+el8.5.0+13436+9c05b4ba.noarch conflicts with file from package python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch
~~~

I'm removing the needinfo flag because I don't see what other information is requested. Apologies if the requested information is not sufficient.

Comment 3 mertensb.mazda 2022-02-03 09:46:53 UTC
After removing the python-podman-api package the update completes successfully:
~~~
$ sudo yum remove python-podman-api                                                                                                               
[sudo] password for bram.mertens:                                                                                                                                                                
Updating Subscription Management repositories.                                                                                                                                                   
Dependencies resolved.                                                                                                                                                                           ================================================================================================================================================================================================= 
Package                              Architecture              Version                                                               Repository                                            Size =================================================================================================================================================================================================
Removing:                                                                                                                                                                                         
python-podman-api                    noarch                    1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526                     @rhel-8-for-x86_64-appstream-rpms                    118 k 
Removing unused dependencies:                                                                                                                                                                     
python3-psutil                       x86_64                    5.4.3-11.el8                                                          @rhel-8-for-x86_64-appstream-rpms                    1.9 M                                                                                                                                                                                                  Transaction Summary                                                                                                                                                                              =================================================================================================================================================================================================
Remove  2 Packages                                                                                                                                                                                                                                                                                                                                                                                Freed space: 2.1 M                                                                                                                                                                               
Is this ok [y/N]: y                                                                                                                                                                              
Running transaction check                                                                                                                                                                        
Transaction check succeeded.                                                                                                                                                                     
Running transaction test                                                                                                                                                                         
Transaction test succeeded.                                                                                                                                                                      
Running transaction                                                                                                                                                                              
  Preparing        :                                                                                                                                                                         1/1
  Erasing          : python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch                                                                                              1/2 
  Erasing          : python3-psutil-5.4.3-11.el8.x86_64                                                                                                                                      2/2 
  Running scriptlet: python3-psutil-5.4.3-11.el8.x86_64                                                                                                                                      2/2 
  Verifying        : python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch                                                                                              1/2 
  Verifying        : python3-psutil-5.4.3-11.el8.x86_64                                                                                                                                      2/2 
Installed products updated.                                                                                                                                                                                                                                                                                                                                                                       Removed:                                                                                                                                                                                         
  python-podman-api-1.2.0-0.2.gitd0a45fe.module+el8.3.1+9857+68fb1526.noarch                                          python3-psutil-5.4.3-11.el8.x86_64                                                                                                                                                                                                                                          Complete!

$ sudo yum install @container-tools
...
Installed products updated.

Upgraded:
  buildah-1:1.23.1-2.module+el8.5.0+13436+9c05b4ba.x86_64                                            cockpit-podman-39-1.module+el8.5.0+13754+92ec836b.noarch                                    
  conmon-2:2.0.32-1.module+el8.5.0+13852+150547f7.x86_64                                             container-selinux-2:2.173.0-1.module+el8.5.0+13852+150547f7.noarch                          
  containernetworking-plugins-1.0.1-1.module+el8.5.0+13436+9c05b4ba.x86_64                           containers-common-2:1-8.module+el8.5.0+13954+1b78b731.noarch                                 
  crun-1.4.1-1.module+el8.5.0+13882+8ad012a9.x86_64                                                  fuse-overlayfs-1.8-1.module+el8.5.0+13754+92ec836b.x86_64                                   
  podman-1:3.4.2-9.module+el8.5.0+13852+150547f7.x86_64                                              podman-catatonit-1:3.4.2-9.module+el8.5.0+13852+150547f7.x86_64                             
  runc-1.0.3-1.module+el8.5.0+13556+7f055e70.x86_64                                                  skopeo-2:1.5.2-1.module+el8.5.0+13517+4134e2e1.x86_64                                       
  udica-0.2.6-1.module+el8.5.0+13436+9c05b4ba.noarch
Installed:
  python3-podman-3.2.1-1.module+el8.5.0+13436+9c05b4ba.noarch                  python3-pytoml-0.1.14-5.git7dea353.el8.noarch                  python3-pyxdg-0.25-16.el8.noarch

Complete!
~~~

I don't know why/how the package was installed. Will monitor if uninstalling it causes any problems.

Comment 4 Coty Sutherland 2022-08-23 12:38:30 UTC
I ran into this same issue when attempting to dnf update on Fedora 36; I don't see a Fedora bug anywhere so dropping a note here in case it's helpful... For me, the python3-podman-api package wasn't even installed, the update was attempting to install it and causing a conflict within itself. To workaround it, I just excluded the package from the upgrade: `dnf update -y --exclude=python3-podman-api`

Comment 5 Blaise Pabon 2022-09-08 12:40:51 UTC
Thank you @csutherl , 

I'm also running Fedora36 server and I ran into this issue and the earlier suggestion of `sudo yum remove python3-podman-api` did not work.

> dnf update -y --exclude=python3-podman-api

did the trick!


Note You need to log in before you can comment on or make changes to this bug.