This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 202673 - udev starts slowly with SELiunx enabled
udev starts slowly with SELiunx enabled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 16:03 EDT by James Morris
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version: udev-095-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 08:03:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Morris 2006-08-15 16:03:03 EDT
udev is starting too slowly with SELinux enabled, because:

"this is at least partly due to the placement of the matchpathcon_init call in
udev, which causes it to read and process the file contexts configuration in
every child process that it forks rather than happening once in the parent."


This is causing kernel developers to disable SELinux, leading to bugs in their
code when SELinux is enabled by users.

This also seems to be causing significant slowdown on OLPC boards.
Comment 1 Harald Hoyer 2006-08-16 08:03:38 EDT
Here we go... fixed in udev-095-6

My start_udev time went down from 7.98s to 4.80s :-)

Note You need to log in before you can comment on or make changes to this bug.