Bug 202684 - vt8251 SATA boot support
vt8251 SATA boot support
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
x86_64 Linux
medium Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2006-08-15 16:27 EDT by Glenn Rottingen
Modified: 2007-12-30 20:32 EST (History)
1 user (show)

See Also:
Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-30 20:32:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Glenn Rottingen 2006-08-15 16:27:51 EDT
Description of problem: SATA Hard Drives not seen by install boot kernel.
ASUS P5VDC-MX mb (Intel Dual Core 64) (via vt8251 chipset).

Version-Release number of selected component (if applicable):x86-64

How reproducible: 
Tried to install several times on this board. All failures.

Install FC6t2 on older ASUS mb with sata drives Athlon 64 no problems with
install, games all ended with an abend when you try to exit. (minesweep, GNOME
balls, etc.)

Steps to Reproduce:
Actual results:

Expected results:

Additional info:  
Installed 2517 kernel on FC5, no problems seeing SATA drives. So vt8251 support
is in FC6t2 2517 kernel but not in the install boot kernel.
Comment 1 Glenn Rottingen 2006-10-02 19:41:41 EDT
I have now tried FC6 Test3 and still can not use this ASUS mother board.  It
still will not access the SATA drives.  This is being writen on that ASUS mother
board, It is now running 64 bit FC5 2054 with special 64 bit AHCI and SATA-VIA

This was supposed to be fixed with the 2.6.18 kernel, will it work on FC6 final
Comment 2 Dave Jones 2006-10-03 02:03:36 EDT
Indeed the ahci driver *should* support this now.
I'm not sure if this went upstream /after/ test3 was cut though.  The FC6Pre
ISOs have it for sure. It'd be good to know if that works or not.
Comment 3 Edward Rudd 2006-11-13 22:33:14 EST
FC6 final does detect the SATA controller chipset on install. It doesn't,
however, access USB or Netork. (I'm filing other bug reports for those issues).
Comment 4 Jon Stanley 2007-12-30 20:32:21 EST
Closing bug per comment #3

Note You need to log in before you can comment on or make changes to this bug.