Bug 2027071 - Rebooting kernel 5.15.4 fails to initialize certain Intel bluetooth devices
Summary: Rebooting kernel 5.15.4 fails to initialize certain Intel bluetooth devices
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 34
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2021-11-28 00:23 UTC by Stan King
Modified: 2022-01-20 14:53 UTC (History)
23 users (show)

Fixed In Version: kernel-5.15.15-100.fc34 kernel-5.15.15-200.fc35
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2022-01-20 08:33:35 UTC
Type: Bug


Attachments (Terms of Use)
kernel messages as requested in item 7 (82.10 KB, text/plain)
2021-11-28 00:23 UTC, Stan King
no flags Details

Description Stan King 2021-11-28 00:23:57 UTC
Created attachment 1843833 [details]
kernel messages as requested in item 7

1. Please describe the problem:

When rebooting a Fedora 34 system with the 5.15.4 kernel, certain Intel bluetooth devices fail to initialize.  The problem is not seen with the 5.14.18 kernel.  A complete power cycling is somewhat successful at avoiding the problem.

Affected devices are listed by lsusb as "ID 8087:0a2a Intel Corp. Bluetooth wireless interface".

Systems with the newer "ID 8087:0029 Intel Corp. AX200 Bluetooth" do not seem to be affected.

Symptomatic messages from dmesg are:

[    9.753998] Bluetooth: hci0: command 0xfc05 tx timeout
[    9.755730] Bluetooth: hci0: Reading Intel version command failed (-110)

This failure may also trigger a SYSSEGV in the Bluetooth device manager on xfce, but that's a separate issue due to non-defensive programming in the user interface.

2. What is the Version-Release number of the kernel:

5.15.4-101.fc34.x86_64

3. Did it work previously in Fedora? If so, what kernel version did the issue
   *first* appear?  Old kernels are available for download at
   https://koji.fedoraproject.org/koji/packageinfo?packageID=8 :

Yes, it works OK with kernel vmlinuz-5.14.18-200.fc34.x86_64


4. Can you reproduce this issue? If so, please provide the steps to reproduce
   the issue below:

Steps to reproduce:

a. Boot an affected system with Fedora
b. Reboot into the 5.15.4 kernel


5. Does this problem occur with the latest Rawhide kernel? To install the
   Rawhide kernel, run ``sudo dnf install fedora-repos-rawhide`` followed by
   ``sudo dnf update --enablerepo=rawhide kernel``:

Didn't try it.


6. Are you running any modules that are not shipped with directly Fedora's kernel?:

No.

7. Please attach the kernel logs. You can get the complete kernel log
   for a boot with ``journalctl --no-hostname -k > dmesg.txt``. If the
   issue occurred on a previous boot, use the journalctl ``-b`` flag.

Will do.

Comment 1 erik 2021-12-03 14:42:49 UTC
I have the exact same problem, with the same dmesg errors.

This bug has also been reported to OpenSuse https://bugzilla.opensuse.org/show_bug.cgi?id=1193124
and to the kernel bugzilla https://bugzilla.kernel.org/show_bug.cgi?id=215167 where it was confirmed to be a regression in kernel 5.15

Comment 2 Didier G 2021-12-22 11:47:52 UTC
I also have the exact same problem with same dmesg messages booting on any 5.15 kernel. 

I have to power off/on my computer to retrieve my BT mouse.

I did not have any problem booting on any pre 5.15 kernel.

Comment 3 Stan King 2021-12-23 17:37:41 UTC
By the way, when dual-booting is an option, booting to the Redmond operating system and back to Linux also usually clears this condition.

Comment 4 Jonathan S 2021-12-24 11:46:46 UTC
I too have the same symptoms as Stan King.

Like him, I have the hardware:

ID 8087:0a2a Intel Corp. Bluetooth wireless interface

Using any kernel 5.15, I too get, on booting, the errors:

Bluetooth: hci0: Reading Intel version command failed (-110)
Bluetooth: hci0: command 0xfc05 tx timeout

Bluetooth does then not work at all.

The latest tested kernel is 5.15.10, but 5.15.11 (currently the latest) shows no fix in the changelog.

There seems to be a recognition from Takashi Iwai, who seems to be a kernel maintainer, in the links given above:

https://bugzilla.redhat.com/show_bug.cgi?id=2027071#c1

that a fix already identified is needed for this 8087:0a2a card, but it seems to have fallen through the cracks.

Meanwhile, I'm using kernel 5.14.18, as the 5.14 kernels don't have this problem.

Comment 5 Justin M. Forbes 2022-01-07 20:05:11 UTC
The fix has not landed in any upstream trees yet (even next). When it does, I will bring it into fedora stable kernels.

Comment 6 Jœrg 2022-01-16 09:43:39 UTC
(In reply to Justin M. Forbes from comment #5)
> The fix has not landed in any upstream trees yet (even next). When it does,
> I will bring it into fedora stable kernels.


     "The fix for this issue is in bluetooth-next and will be merged to mainline soon."
     "https://git.kernel.org/pub/scm/linux/kernel/git/bluetooth/bluetooth-next.git/commit/?id=95655456e7cee858a23793f67025765b4c4c227b"


Source: https://lore.kernel.org/lkml/246bd180-4d8f-ae2b-1b51-90eaf194803c@leemhuis.info/T/#m77ab9e84eec72d1b3e16d6862ffb1a2670277d94

Comment 7 Fedora Update System 2022-01-17 18:11:03 UTC
FEDORA-2022-b7ef5c55da has been submitted as an update to Fedora 34. https://bodhi.fedoraproject.org/updates/FEDORA-2022-b7ef5c55da

Comment 8 Fedora Update System 2022-01-17 18:11:10 UTC
FEDORA-2022-a23dd56848 has been submitted as an update to Fedora 35. https://bodhi.fedoraproject.org/updates/FEDORA-2022-a23dd56848

Comment 9 Jœrg 2022-01-17 21:03:57 UTC
Installed on Fedora 35 and after Reboot Bluetooth is working fine with 'Intel(R) Dual Band Wireless AC 3165'

$ lsusb
Bus 001 Device 004: ID 8087:0a2a Intel Corp. Bluetooth wireless interface

Comment 10 Fedora Update System 2022-01-18 01:23:30 UTC
FEDORA-2022-b7ef5c55da has been pushed to the Fedora 34 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-b7ef5c55da`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-b7ef5c55da

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 11 Fedora Update System 2022-01-18 01:44:31 UTC
FEDORA-2022-a23dd56848 has been pushed to the Fedora 35 testing repository.
Soon you'll be able to install the update with the following command:
`sudo dnf upgrade --enablerepo=updates-testing --advisory=FEDORA-2022-a23dd56848`
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2022-a23dd56848

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 12 Stan King 2022-01-19 04:23:35 UTC
The testing version of the kernel in Comment 11 seems to work for me on the affected hardware.

It still seems to skip the firmware reload in case of a "warm" reboot, as distinct from a power cycle.  One could reasonably wonder how wise that is.  Here is the message that makes me believe that this is the case:

    Bluetooth: hci0: Intel device is already patched. patch num: 32

Whereas after a power cycle, this message is issued instead:

    Bluetooth: hci0: Intel BT fw patch 0x32 completed & activated

Comment 13 Fedora Update System 2022-01-20 08:33:35 UTC
FEDORA-2022-b7ef5c55da has been pushed to the Fedora 34 stable repository.
If problem still persists, please make note of it in this bug report.

Comment 14 Fedora Update System 2022-01-20 14:53:26 UTC
FEDORA-2022-a23dd56848 has been pushed to the Fedora 35 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.