Bug 202735 - snd-azx sound driver broken in kernel 2.6.9-42.EL on RHEL4
snd-azx sound driver broken in kernel 2.6.9-42.EL on RHEL4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-15 22:30 EDT by Charalampos.tsimenidis@ncl.ac.uk
Modified: 2007-11-16 20:14 EST (History)
6 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-07 23:19:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Charalampos.tsimenidis@ncl.ac.uk 2006-08-15 22:30:32 EDT
Description of problem:

The snd-azx sound driver in the latest RHEL4 kernel (2.6.9-42.EL) 
is broken on my Dell precision workstation 380 (sigmatel).
I don't get any errors while loading the driver and everything
seems to be ok with the mixer but no sound is coming out and
the mixer is unmuted.
 
Downgrading to 2.6.9-34.0.2.EL seems to fix the problem.

Version-Release number of selected component (if applicable):
2.6.9-42.EL

How reproducible:


Steps to Reproduce:
1. Boot into kernel-2.6.9-34.0.2.EL: sound ok
2. Boot into kernel-2.6.9-42.EL: no sound
  
Actual results:


Expected results:


Additional info:
Sound entry in /etc/modprobe.conf

alias snd-card-0 snd-azx
options snd-card-0 index=0
install snd-azx /sbin/modprobe --ignore-install snd-azx && /usr/sbin/alsactl
restore >/dev/null 2>&1 || :
remove snd-azx { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; };
/sbin/modprobe -r --ignore-remove snd-azx
Comment 1 John W. Linville 2006-08-22 13:57:03 EDT
Test kernels w/ update azx driver available here:

   http://people.redhat.com/linville/kernels/rhel4/

Please give them a try and post the results here...thanks!
Comment 2 Charalampos.tsimenidis@ncl.ac.uk 2006-08-23 09:58:17 EDT
For some reason the modules snd-azx.ko and snd-hda-codec.ko are not included 
in the test kernel (kernel-2.6.9-42.2.EL.jwltest.158.i686.rpm) !

$rpm -ql kernel-2.6.9-42.2.EL.jwltest.158 | grep azx
returns an empty string.
Comment 3 John W. Linville 2006-08-23 13:25:15 EDT
I'm terribly sorry -- I screwed-up a Makefile during the update...

It is fixed in the kernels available now at the same location as in comment 1.  
Please try again?
Comment 4 Charalampos.tsimenidis@ncl.ac.uk 2006-08-23 14:57:57 EDT
I still see the old rpm packages without the azx driver.
Comment 5 John W. Linville 2006-08-23 15:12:38 EDT
Seems to be there now?  Sorry for the confusion!
Comment 6 Charalampos.tsimenidis@ncl.ac.uk 2006-08-24 07:12:50 EDT
It seems the problem has been fixed now in the test 
kernel (2.6.9-42.2.EL.jwltest.160).

Many Thanks
Comment 7 RHEL Product and Program Management 2006-09-07 15:02:28 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 8 RHEL Product and Program Management 2006-09-07 15:02:29 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 10 John W. Linville 2006-10-25 14:42:46 EDT
My test kernels have had some patch churn, and I'm not sure that previous 
testing for this issue is still valid.  Please retest the kernels at the 
location from comment 13 and post the results here ASAP...th
Comment 11 Andrew Schultz 2006-10-25 14:49:37 EDT
(comment 13...? what happened to comment 9?)

I've been running an SMP 2.6.9-42.0.3.EL kernel patched with
jwltest-azx-broadwater.patch with no problems since the release of 42.0.3.EL
Comment 12 John W. Linville 2006-10-25 15:04:32 EDT
Oh, sorry -- sloppy cut and paste...

It should have read "location from comment 1", and the "...th" should have 
been "...thanks!" :-)

Andrew, thanks for the confirmation.  Charalampos & tjb, are either 
2.6.9-42.0.3.EL or the current test kernels working for you as well?
Comment 13 Thomas J. Baker 2006-10-25 15:13:04 EDT
I will hopefully get to test this tomorrow. The user who has the problem is out
this afternoon.
Comment 14 Charalampos.tsimenidis@ncl.ac.uk 2006-10-25 17:25:12 EDT
Kernel 2.6.9-42.20.EL.jwltest.170 seems to work fine here.
Comment 16 Jason Baron 2006-10-31 10:48:21 EST
committed in stream U5 build 42.22. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 17 daryl herzmann 2006-11-06 19:45:45 EST
Hi,

Me too :)  I've got a Dell D820 and sound works on: 2.6.9-34.0.2.ELsmp , but
does not work for me on:

kernel-smp-2.6.9-42.EL
kernel-smp-2.6.9-42.0.2.EL
kernel-smp-2.6.9-42.0.3.EL
kernel-smp-2.6.9-42.23.EL  (from jbaron repo)
kernel-smp-2.6.9-42.22.EL.jwltest.175

lspci -v reports

00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
        Subsystem: Dell: Unknown device 01cc
        Flags: bus master, fast devsel, latency 0, IRQ 177
        Memory at dfffc000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: 64bit+ Queue=0/0 Enable-
        Capabilities: [70] Express Unknown type IRQ 0
        Capabilities: [100] Virtual Channel
        Capabilities: [130] Unknown (5)

I would be happy to test any ideas you may have...

thanks!
Comment 18 John W. Linville 2006-11-20 10:38:56 EST
Daryl, could you open a new bug particular to the Dell D820?  This one was 
opened for the D380, which appears to now be resolved.
Comment 19 daryl herzmann 2006-11-20 10:53:38 EST
Thanks for the response and sorry for hijacking this bug.  My new entry is here:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=216447
Comment 20 Vivian LeFebvre 2006-12-11 15:29:02 EST
John,
I am having similar problems on Dell Precisions.  I have followed yor
recommendations that you gave Charalampos, but the kernel has changed since this
ticket was opened.  I have loaded the kernel /2.6.9-42.30.EL-largesmp-x86_64
from site: http://people.redhat.com/~jbaron/rhel4/RPMS.kernel/

When I do a rpm tp determine if it is included, it looks as thoug it is but I am
still not getting the sound to work.  Do you have any ideas?
Thanks --Vivian (Vivian.A.LeFebvre@noaa.gov)

$ rpm -ql kernel-largesmp-devel-2.6.9-42.30.EL | grep azx
/usr/src/kernels/2.6.9-42.30.EL-largesmp-x86_64/include/config/snd/azx
/usr/src/kernels/2.6.9-42.30.EL-largesmp-x86_64/include/config/snd/azx/module.h
/usr/src/kernels/2.6.9-42.30.EL-largesmp-x86_64/sound/pci/azx
/usr/src/kernels/2.6.9-42.30.EL-largesmp-x86_64/sound/pci/azx/Makefile


# lspci
00:00.0 Host bridge: Intel Corporation 975X Express Memory Controller Hub
00:01.0 PCI bridge: Intel Corporation 975X Express PCI Express Root Port
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition
Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1
(rev 01)
00:1c.4 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express
Port 5 (rev 01)
00:1c.5 PCI bridge: Intel Corporation 82801GR/GH/GHM (ICH7 Family) PCI Express
Port 6 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI
Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface
Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller
(rev 01)
00:1f.2 SATA controller: Intel Corporation 82801GR/GH (ICH7 Family) Serial ATA
Storage Controller AHCI (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: nVidia Corporation GeForce 7900 GT (rev a1)
03:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5721 Gigabit
Ethernet PCI Express (rev 21)
04:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5754 Gigabit
Ethernet PCI Express (rev 02)
05:02.0 FireWire (IEEE 1394): Agere Systems FW323 (rev 61)
Comment 21 Vivian LeFebvre 2006-12-12 10:02:44 EST
I will open a new ticket for the Precision 670n machines.
--Vivian
Comment 22 James E. Leinweber 2007-01-31 15:55:19 EST
On a Dell precision 380 running RHEL 4.X x86_64 I had sound on update 3, but
never yet on update 4.  In particular yesterday's 2.6.9-42.0.8.ELsmp still
doesn't.  Some of the experimental kernels have been OK; I just switched from
2.6.9-42.3.EL.jwltest.161smp to jbaron's 1/31/07 build of 2.6.9-45.ELsmp.
Comment 25 Red Hat Bugzilla 2007-05-07 23:19:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.