Bug 2027637 - (release-4.9) Gather ValidatingWebhookConfiguration and MutatingWebhookConfiguration resource definitions
Summary: (release-4.9) Gather ValidatingWebhookConfiguration and MutatingWebhookConfig...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Insights Operator
Version: 4.9
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 4.9.z
Assignee: Tomas Remes
QA Contact: Joao Fula
URL:
Whiteboard:
Depends On: 2027629
Blocks: 2027720
TreeView+ depends on / blocked
 
Reported: 2021-11-30 10:15 UTC by Tomas Remes
Modified: 2021-12-13 12:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 2027629
: 2027720 (view as bug list)
Environment:
Last Closed: 2021-12-13 12:06:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github openshift insights-operator pull 559 0 None open [release-4.9] Bug 2027637: gather webhook configurations 2021-12-01 07:07:32 UTC
Red Hat Product Errata RHBA-2021:5003 0 None None None 2021-12-13 12:06:53 UTC

Description Tomas Remes 2021-11-30 10:15:10 UTC
+++ This bug was initially created as a clone of Bug #2027629 +++

Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Tomas Remes on 2021-11-30 10:12:34 UTC ---

This was addressed with https://github.com/openshift/insights-operator/pull/508, moving to ON_QA.

Comment 2 Joao Fula 2021-12-06 08:38:33 UTC
Verified on 4.9.0-0.nightly-2021-12-03-233811.

Verification steps:

1. Download an insights-operator archive
2. Check resources by running
  oc get mutatingwebhookconfigurations.admissionregistration.k8s.io
  oc get validatingwebhookconfigurations.admissionregistration.k8s.io
3. Check files in /config/mutatingwebhookconfigurations 
   Check files in /config/validatingwebhookconfigurations
4. The files from mutatingwebhookconfigurations should match between step 2 and 3
   The files from validatingwebhookconfigurations should match between step 2 and 3

Comment 5 errata-xmlrpc 2021-12-13 12:06:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (OpenShift Container Platform 4.9.11 bug fix update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2021:5003


Note You need to log in before you can comment on or make changes to this bug.