Bug 202764 - Synce package is outdated, and does not sync with WM2005
Synce package is outdated, and does not sync with WM2005
Product: Fedora
Classification: Fedora
Component: synce (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2006-08-16 08:34 EDT by Renato Ramonda
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-05-02 17:57:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Updated spec file for 0.9.3 components (6.86 KB, text/plain)
2007-02-12 18:46 EST, Eric Work
no flags Details
Needed patch for compiling new vdccm component (392 bytes, patch)
2007-02-12 18:48 EST, Eric Work
no flags Details | Diff
New spec file for gnome trayicon (2.24 KB, text/plain)
2007-02-12 20:36 EST, Eric Work
no flags Details
Needed patch for new synce-trayicon (6.58 KB, patch)
2007-02-12 20:37 EST, Eric Work
no flags Details | Diff

  None (edit)
Description Renato Ramonda 2006-08-16 08:34:46 EDT
Description of problem:

According to the docs on the synce website to interact with devices using
Windows Mobile 2005 (or 5.0) you have to use libsynce 0.9.2 and some other packages.
for reference.

Is it possible to update the synce release of fedora, so that at least managing
the installed applications will be possible?

I'm willing to wait for sync support (it still requires some patching here and
there, I think), but install/file management would be the bare minimum to make
full use of a WM2005 device with fedora.

Please, would it be possible to see an update for this package(s) soon?
Comment 1 Andreas Bierfert 2006-08-16 12:02:00 EDT
Thanks for reporting its on my todo now.
Comment 2 Andreas Bierfert 2006-08-22 04:43:43 EDT
After looking at this a bit it seems to me that there is no official 0.9.2
release yet but only a partial upgrade to get WM2005 working... So I don't know
if I really should upgrade... I will see if I can reach a developer and get a
Comment 3 Renato Ramonda 2006-08-22 04:48:11 EDT
Apparently WM2005 needs some packages "on top" of the normal 0.9.1 synce package
(libsynce, the fake network proxy, and so on).

Maybe they could be released as addon packages, without disrupting the normal
synce package.
(don't know if it is at all possible, plese, do ask the devs)
Comment 4 Andreas Bierfert 2006-09-17 11:17:54 EDT
I have an WM2005 device here now to test everything but adding the extra
packages may prove a bit tricky ... I will see what I can do
Comment 5 Renato Ramonda 2006-09-17 15:39:51 EDT
Did you manage to compile the packages at all?
I tried to build them from source, but compilation always fails on a 'slang.h'
error, even if I have slang and slang-devel, and the ./configure step works
without errors.
Comment 6 Eric Work 2007-02-12 17:26:21 EST
There seems to be some 0.9.3 tar.gz files now which updates for a few of the
components.  Would it be possible to replace these components with the newer
0.9.3 versions.
Comment 7 Eric Work 2007-02-12 18:46:59 EST
Created attachment 147942 [details]
Updated spec file for 0.9.3 components

This should be a good start for the new package.
Comment 8 Eric Work 2007-02-12 18:48:48 EST
Created attachment 147944 [details]
Needed patch for compiling new vdccm component

This is also needed with the new spec file.
Comment 9 Eric Work 2007-02-12 20:36:12 EST
Created attachment 147952 [details]
New spec file for gnome trayicon

With the new 0.9.3 packages I have my device working (rx1950 in USB serial
mode, WM2005) but noticed that the trayicon needed updating.
Comment 10 Eric Work 2007-02-12 20:37:28 EST
Created attachment 147953 [details]
Needed patch for new synce-trayicon

This changes dccm to vdccm throughout the entire source code to work with the
new synce libraries.
Comment 11 Eric Work 2007-02-12 20:40:34 EST
I had to add this:


to the end of the configure line for synce-trayicon to compile.  I'm sure the
other dependent packages will also need some changing to compile with the 0.9.3
version of librapi.
Comment 12 Andreas Bierfert 2007-02-13 03:01:37 EST
Thanks for your work on this :) I looked at it seems ok to me... the question
is: do we know if with these upgrades the older devices still work? If yes then
I will push everything asap.
Comment 13 Eric Work 2007-02-13 03:11:44 EST
I'm not sure I only have a WM2005 device.  It seems like it would work since I
used the WM2003 directions with my device in USB Serial Mode.  I needed at least
0.9.2 so my device wouldn't disconnect after about 30 seconds.  I have been
using it all day today with no problems.  We might need to find someone who has
an older device working currently to test the new packages.
Comment 14 Andreas Bierfert 2007-02-13 03:19:50 EST
Ok. Then I will prep all packages and push them to devel tonight or tomorrow so
we can get some testing. Once we know if everything works I will push it to
fc{5,6} as well.
Comment 15 Eric Work 2007-02-13 03:25:24 EST
Sounds like a plan.  Remember to check that the devel packages which require
synce still build.  I think they might need some tweaking since librapi and
libsynce now use pkgconfig (maybe add as a build req).
Comment 16 Andreas Bierfert 2007-02-27 12:23:35 EST
Just as a quick status upgrade: I am working on this. I am still fixing rpath
issues on this. I hope I will be done with this and all things depending on it
sometime this week...
Comment 17 Renato Ramonda 2007-02-28 03:04:18 EST
Uhm... my understanding was that even vdccm had been scrapped, and in my later
experiments I've used "odccm", a complete rewrite (I followed the wiki
instructions for WM2005 that have been updated only in part).

It's clunky, since having built things by hand I have to start odccm by hand,
and such, but I have managed to obtain a network between my machine and the
pocketpc device.

Do we have some kind of statement from the synce guys saying what is the set of
packages to use?
Comment 18 Eric Work 2007-02-28 21:35:17 EST
I also noticed that in SVN they now use odccm but the 0.9.3 source packages
include vdccm.  I followed the instructions on the synce wiki for building
WM2005 support from sourceforge packages for which 0.9.3 is the latest.  If you
patch the tray-icon to use vdccm (or odccm i guess) then you can add it to your
session start-up and then just connect the device (after all the prep).  Then
just right click disconnect from the tray-icon when you're done and disconnect
the USB.  Next time you plugin the device it comes right up again.  The one
problem I've run into so far using my 0.9.3 RPMs is that the gnomevfs plugin
seems to have problems refreshing.

Note You need to log in before you can comment on or make changes to this bug.