Bug 202785 - [classpath] Frysk - if user data is defined in $HOME/.frysk - debug messages are displayed when GUI is started
[classpath] Frysk - if user data is defined in $HOME/.frysk - debug messages ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: gcc (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
Len DiMaggio
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-16 10:03 EDT by Len DiMaggio
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.1.1-24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-27 01:58:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Len DiMaggio 2006-08-16 10:03:43 EDT
Description of problem:
Frysk - if user data is defined in $HOME/.frysk - debug messages are displayed
when GUI is started

Version-Release number of selected component (if applicable):
RHEL5-Server-20060806.1

How reproducible:
100%

Steps to Reproduce:
1. Run the Frysk GUI, create a session, save it, exit Frysk
2. Re-enter Frysk GUI
  
Actual results:

[root@rocco frysk]# frysk
Found subnode: /theManager
Found subnode: /theManager/logWindow
Found subnode: /theManager/mainWindow
Key: size.width Value: 640
Key: size.height Value: 480
Key: position.y Value: 272
Key: position.x Value: 320
Found subnode: /theManager/mainWindow/allProcWidget
Key: vPane.position Value: 200

Expected results:
Debug messages should not be displayed

Additional info:
Comment 1 Phil Muldoon 2006-08-16 10:10:25 EDT
Those are not debug messages, but rather output from
java.utils.prefs.Preferences when a preference file is read and parsed. There
appears to be no way to turn these off (they are not output by Frysk), when I
looked at the issue before.
Comment 2 Andrew Cagney 2006-08-16 10:24:23 EDT
Something to do with a logger?

Long term, frysk should use gconf to pick up its configuration information
making it compatible with the rest of gnome.
Comment 3 Phil Muldoon 2006-08-16 10:27:38 EDT
#2

Nothing to do with the logger. It just console spam that comes from running
preferences. I''ll ask the classpath people to see if we can block it short term
somehow.

And fully agreed on migration to gconf. (the gnome way of doing preferences over
the java way of doing preferences)
Comment 4 Mark Wielaard 2006-08-18 11:33:59 EDT
Bug in classpath/libgcj. It had some System.out.println() debug statements left
in the source of NodeReader:

diff -u -r1.5 NodeReader.java
--- gnu/java/util/prefs/NodeReader.java 2 Jul 2005 20:32:15 -0000       1.5
+++ gnu/java/util/prefs/NodeReader.java 18 Aug 2006 15:41:53 -0000
@@ -124,7 +124,6 @@
             skipTill("name=\"");
             String name = readTill("\"");
             Preferences subnode = node.node(name);
-            System.out.println("Found subnode: " + subnode.absolutePath());
             readMap(subnode);
             readNodes(subnode);
             skipTill("</node>");
@@ -160,7 +159,6 @@
             String key = readTill("\"");
             skipTill("value=\"");
             String value = readTill("\"");
-            System.out.println("Key: " + key + " Value: " + value);
             node.put(key, value);
         }
     }

BTW. Since 0.92 the default util.pref backend for classpath is based on GConf2.
Comment 5 Mark Wielaard 2006-09-18 11:50:15 EDT
Patch in comment #4 has been included in the libgcj in fc6/rawhide.

Note You need to log in before you can comment on or make changes to this bug.