Bug 202789 - nautilus crashes on login
nautilus crashes on login
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: nautilus (Show other bugs)
rawhide
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks: FC6Blocker
  Show dependency treegraph
 
Reported: 2006-08-16 10:33 EDT by Kevin DeKorte
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-16 18:13:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin DeKorte 2006-08-16 10:33:32 EDT
Description of problem:
After upgrading rawhide to Aug 16th nautilus crashes on login

Version-Release number of selected component (if applicable):
nautilus-2.15.91-2.fc6
libgnomeui-2.15.91-1.fc6

How reproducible:
100%

Steps to Reproduce:
1. login with gnome as the window manager
2. crash
3.
  
Actual results:
nautilus crashes

Expected results:
nautilus should run

Additional info:

Distribution: Fedora Core release 5.91 (FC6 Test2)
Gnome Release: 2.15.91 2006-08-13 (Red Hat, Inc)
BugBuddy Version: 2.15.90

Memory status: size: 26030080 vsize: 0 resident: 26030080 share: 0 rss: 7331840
rss_rlim: 0
CPU usage: start_time: 1155739329 rtime: 0 utime: 5 stime: 0 cutime:3 cstime: 0
timeout: 2 it_real_value: 0 frequency: 0

Backtrace was generated from '/usr/bin/nautilus'

(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208390912 (LWP 2833)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0xb7fbc402 in __kernel_vsyscall ()
#0  0xb7fbc402 in __kernel_vsyscall ()
#1  0x00184983 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x00bdfd66 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
#3  <signal handler called>
#4  0x08066161 in POA_Nautilus_MetafileMonitor__init ()
#5  0x00d3223c in __libc_start_main () from /lib/libc.so.6
#6  0x08064c81 in ?? ()

Thread 1 (Thread -1208390912 (LWP 2833)):
#0  0xb7fbc402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00184983 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x00bdfd66 in gnome_gtk_module_info_get () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#3  <signal handler called>
No symbol table info available.
#4  0x08066161 in POA_Nautilus_MetafileMonitor__init ()
No symbol table info available.
#5  0x00d3223c in __libc_start_main () from /lib/libc.so.6
No symbol table info available.
#6  0x08064c81 in ?? ()
No symbol table info available.
#0  0xb7fbc402 in __kernel_vsyscall ()
Comment 1 Ray Strode [halfline] 2006-08-16 11:06:05 EDT
do you have accessibility enabled?
Comment 2 Alexander Larsson 2006-08-16 11:07:18 EDT
Could you install the nautilus-debuginfo, gtk2-debuginfo and
libgnomeui-debuginfo packages and get a new backtrace? Its hard to get much
information from this one.
Comment 3 Kevin DeKorte 2006-08-16 11:35:08 EDT
After installing those packages and rerunning nautilus (under xfce)

Distribution: Fedora Core release 5.91 (FC6 Test2)
Gnome Release: 2.15.91 2006-08-13 (Red Hat, Inc)
BugBuddy Version: 2.15.90

Memory status: size: 26025984 vsize: 0 resident: 26025984 share: 0 rss: 7233536
rss_rlim: 0
CPU usage: start_time: 1155742840 rtime: 0 utime: 5 stime: 0 cutime:4 cstime: 0
timeout: 1 it_real_value: 0 frequency: 0

Backtrace was generated from '/usr/bin/nautilus'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208538368 (LWP 3481)]
0xb7f98402 in __kernel_vsyscall ()
#0  0xb7f98402 in __kernel_vsyscall ()
#1  0x005fe983 in __waitpid_nocancel () from /lib/libpthread.so.0
#2  0x00162d66 in libgnomeui_segv_handle (signum=11) at gnome-ui-init.c:867
#3  <signal handler called>
#4  0x08066161 in get_skel_small_Nautilus_Metafile (servant=0x8e0f110, 
    opname=0x81364bc "U\211åWVS\203ì\fè", m_data=0xbff8e188, impl=0x79323c)
    at nautilus-shell-interface-skels.c:227
#5  0x0079323c in __libc_start_main () from /lib/libc.so.6
#6  0x08064c81 in _start ()

Thread 1 (Thread -1208538368 (LWP 3481)):
#0  0xb7f98402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x005fe983 in __waitpid_nocancel () from /lib/libpthread.so.0
No symbol table info available.
#2  0x00162d66 in libgnomeui_segv_handle (signum=11) at gnome-ui-init.c:867
	estatus = 9127260
	sa = {__sigaction_handler = {sa_handler = 0, sa_sigaction = 0}, 
  sa_mask = {__val = {8271057, 0, 9121780, 8268241, 5447177, 9030183, 0, 
      9030183, 9126176, 257, 9126212, 9126212, 0, 9126232, 56, 9037912, 
      149144760, 64, 94998144, 8262475, 9121780, 9126176, 248, 3220757548, 
      8271057, 149144760, 135808576, 3220757416, 5608993, 149144760, 9121780, 
      3}}, sa_flags = 149147040, sa_restorer = 0xbff8dbd8}
	pid = 0
	in_segv = 1
#3  <signal handler called>
No symbol table info available.
#4  0x08066161 in get_skel_small_Nautilus_Metafile (servant=0x8e0f110, 
    opname=0x81364bc "U\211åWVS\203ì\fè", m_data=0xbff8e188, impl=0x79323c)
    at nautilus-shell-interface-skels.c:227
	_t_ = (ORBit_IInterface * volatile) 0xbff8e130
#5  0x0079323c in __libc_start_main () from /lib/libc.so.6
No symbol table info available.
#6  0x08064c81 in _start ()
No symbol table info available.
#0  0xb7f98402 in __kernel_vsyscall ()
Comment 4 Kevin DeKorte 2006-08-16 11:39:46 EDT
(In reply to comment #1)
> do you have accessibility enabled?

I do not believe I do. How can I verify?
Comment 5 Matthias Clasen 2006-08-16 11:56:17 EDT
If you start a gtk app on the command line, it will tell you
Comment 6 Kevin DeKorte 2006-08-16 12:12:48 EDT
(In reply to comment #5)
> If you start a gtk app on the command line, it will tell you

Then no I don't. I also went into the Gnome Control Center and verified that
Assistive Technology was not enabled (unchecked)
Comment 7 Kevin DeKorte 2006-08-16 12:18:25 EDT
BTW. I had done an update on 8/15 (and rebooted) and everything worked and was
working prior to the 8/16 yum update. I noticed that neither nautilus or
libgnomeui were updated on 8/16. So I am wondering if those are not the problem
areas.  

I have also tried running nautilus over ssh -X with a 100% clean user (rm -rf *
and rm -rf .* in the users home directory) and nautilus still crashes with the
same errors.
Comment 8 Kevin DeKorte 2006-08-16 14:12:26 EDT
Here is another Bug Buddy Dump with glibc-debuginfo and glibc-debuginfo-common
installed. Also when bug buddy first comes up it says there is an error in the
CD/DVD Creator application. I have tried removing the nautilus-cd-burner rpm but
that wants to remove gnome-session which I don't think would be good. The
version of nautilus-cd-burner is 2.15.6-1.fc6 and is from the development repo.

Distribution: Fedora Core release 5.91 (FC6 Test2)
Gnome Release: 2.15.91 2006-08-13 (Red Hat, Inc)
BugBuddy Version: 2.15.90

Memory status: size: 26025984 vsize: 0 resident: 26025984 share: 0 rss: 7114752
rss_rlim: 0
CPU usage: start_time: 1155752348 rtime: 0 utime: 5 stime: 0 cutime:4 cstime: 0
timeout: 1 it_real_value: 0 frequency: 0

Backtrace was generated from '/usr/bin/nautilus'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208685824 (LWP 5736)]
0xb7f74402 in __kernel_vsyscall ()
#0  0xb7f74402 in __kernel_vsyscall ()
#1  0x00280983 in ?? () from /lib/libpthread.so.0
#2  0x00162d66 in libgnomeui_segv_handle (signum=11) at gnome-ui-init.c:867
#3  <signal handler called>
#4  0x08066161 in get_skel_small_Nautilus_Metafile (servant=0x8b33110,
opname=0x81364bc "U\211åWVS\203ì\fè", 
    m_data=0xbfb7d568, impl=0xeb823c) at nautilus-shell-interface-skels.c:227
#5  0x00eb823c in __libc_start_main (main=0x8078a80 <main>, argc=1,
ubp_av=0xbfb7d594, 
    init=0x81364bc <__libc_csu_init>, fini=0x81364b4 <__libc_csu_fini>,
rtld_fini=0x31b270 <_dl_fini>, 
    stack_end=0xbfb7d58c) at libc-start.c:231
#6  0x08064c81 in _start ()

Thread 1 (Thread -1208685824 (LWP 5736)):
#0  0xb7f74402 in __kernel_vsyscall ()
No symbol table info available.
#1  0x00280983 in ?? () from /lib/libpthread.so.0
No symbol table info available.
#2  0x00162d66 in libgnomeui_segv_handle (signum=11) at gnome-ui-init.c:867
	estatus = 16618844
	sa = {__sigaction_handler = {sa_handler = 0, sa_sigaction = 0}, sa_mask =
{__val = {15762641, 0, 16613364, 
      15759825, 14466569, 16521767, 0, 16521767, 16617760, 257, 16617796,
16617796, 0, 16617816, 56, 16529496, 
      146146488, 64, 94998144, 15754059, 16613364, 16617760, 248, 3216494604,
15762641, 146146488, 135808576, 
      3216494472, 14628385, 146146488, 16613364, 3}}, sa_flags = 146148768,
sa_restorer = 0xbfb7cfb8}
	pid = 0
	in_segv = 1
#3  <signal handler called>
No symbol table info available.
#4  0x08066161 in get_skel_small_Nautilus_Metafile (servant=0x8b33110,
opname=0x81364bc "U\211åWVS\203ì\fè", 
    m_data=0xbfb7d568, impl=0xeb823c) at nautilus-shell-interface-skels.c:227
	_t_ = (ORBit_IInterface * volatile) 0xbfb7d510
#5  0x00eb823c in __libc_start_main (main=0x8078a80 <main>, argc=1,
ubp_av=0xbfb7d594, 
    init=0x81364bc <__libc_csu_init>, fini=0x81364b4 <__libc_csu_fini>,
rtld_fini=0x31b270 <_dl_fini>, 
    stack_end=0xbfb7d58c) at libc-start.c:231
	result = <value optimized out>
	unwind_buf = {cancel_jmp_buf = {{jmp_buf = {16613364, 3304608, 0, -1078471320,
920807329, -1984024400}, 
      mask_was_saved = 0}}, priv = {pad = {0x0, 0x0, 0x31fce0, 0xeb816d}, data =
{prev = 0x0, cleanup = 0x0, 
      canceltype = 3276000}}}
	not_first_call = <value optimized out>
#6  0x08064c81 in _start ()
No symbol table info available.
#0  0xb7f74402 in __kernel_vsyscall ()
Comment 9 Kevin DeKorte 2006-08-16 14:37:02 EDT
I did some gdb work on this... and found the following.. looks like there needs
to be a NULL check on servant->vepv->Nautilus_Metafile_epv at line 233 of
nautilus-shell-interface-skels.c

list
227     *impl = (gpointer)servant->vepv->Nautilus_Metafile_epv->set;
228     {ORBit_IInterface *volatile _t_=&Nautilus_Metafile__iinterface;*m_data =
(gpointer)&_t_->methods._buffer [3];}
229     return (ORBitSmallSkeleton)_ORBIT_skel_small_Nautilus_Metafile_set;
230     break;
231     case '_':
232     if(strcmp((opname + 4), "list")) break;
233     *impl = (gpointer)servant->vepv->Nautilus_Metafile_epv->set_list;
234     {ORBit_IInterface *volatile _t_=&Nautilus_Metafile__iinterface;*m_data =
(gpointer)&_t_->methods._buffer [4];}
235     return (ORBitSmallSkeleton)_ORBIT_skel_small_Nautilus_Metafile_set_list;
236     break;
(gdb) print opname
$1 = 0x81364bc "U\211�WVS\203�\f
(gdb) print opname + 4
$2 = 0x81364c0 "VS\203�\f
(gdb) print servant
$3 = (POA_Nautilus_Metafile *) 0x9d7f110
(gdb) print servant->vepv
$4 = (POA_Nautilus_Metafile__vepv *) 0x9d7ed10
(gdb) print servant->vepv->Nautilus_Metafile_epv
$5 = (POA_Nautilus_Metafile__epv *) 0x0
(gdb) bt
#0  0x08066161 in get_skel_small_Nautilus_Metafile (servant=0x9d7f110, 
    opname=0x81364bc "U\211�WVS\203�\f�", m_data=0xbff86158, impl=0xe0423c)
    at nautilus-shell-interface-skels.c:227
#1  0x00e0423c in __libc_start_main (main=0x8078a80 <main>, argc=1, 
    ubp_av=0xbff86184, init=0x81364bc <__libc_csu_init>, 
    fini=0x81364b4 <__libc_csu_fini>, rtld_fini=0xfb7270 <_dl_fini>, 
    stack_end=0xbff8617c) at libc-start.c:231
#2  0x08064c81 in _start ()
Comment 10 Kevin DeKorte 2006-08-16 17:17:09 EDT
ok, I rebuilt the nautilus and nautilus-cd-burner rpms and installed them and
that seemed to fix the problems I have. 

So I guess this can be closed.
Comment 11 Matthias Clasen 2006-08-16 18:13:29 EDT
hmm, slightly disconcerting, but if nobody else has seen this, then it is indeed
best to close this bug.

Note You need to log in before you can comment on or make changes to this bug.