Bug 20281 - Yet another gcc 2.96 internal error
Yet another gcc 2.96 internal error
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gcc (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-11-03 09:10 EST by Randy Cushman
Modified: 2007-04-18 12:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-05 11:50:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
compiler output (1.02 MB, text/plain)
2000-11-05 11:47 EST, Randy Cushman
no flags Details

  None (edit)
Description Randy Cushman 2000-11-03 09:10:36 EST
I receive an error when attempting to build Pilot Emulator (a program that
emulates devices that run PalmOS, such as Palm Pilots.)

I installed gcc-2.96-60.i386.rpm and gcc-c++-2.96-60.i386.rpm.  This made
no difference.

As a workaround I tried 'chroot' to a RHL 6.0 partition, then performed
'./configure' and 'make', but when I went back to RHL 7.0, 'make install'
attempted to rebuild the software.

Instructions to demonstrate problem:
Go to http://www.palmos.com/dev/tech/tools/emulator/
Download emulator-unix.tar.gz (click 'Unix' under 'Download the Emulator')
tar -xzf emulator-unix.tar.gz
cd Emulator_Src_3.0a7/BuildUnix
./configure
make MetaMemory.o

Problem detail:
c++ -DHAVE_DIRENT_H=1 -DSTDC_HEADERS=1 -DHAVE_ENDIAN_H=1 -DHAVE_FCNTL_H=1
-DHAVE_LIMITS_H=1 -DHAVE_STRINGS_H=1 -DHAVE_SYS_TIME_H=1 -DHAVE_UNISTD_H=1
-DHAVE_TYPE_SOCKLEN_T=1 -DHAVE_ALLOCA_H=1 -DHAVE_ALLOCA=1 -DHAVE_MKDIR=1
-DHAVE_LIBFLTK=1  -I. -I.  -I./../SrcShared -I./../SrcShared/Hardware
-I./../SrcShared/Palm/Device
-I./../SrcShared/Palm/Platform/Core/Hardware/IncsPrv
-I./../SrcShared/Palm/Platform/Core/System/IncsPrv
-I./../SrcShared/Palm/Platform/Incs
-I./../SrcShared/Palm/Platform/Incs/Core
-I./../SrcShared/Palm/Platform/Incs/Core/Hardware
-I./../SrcShared/Palm/Platform/Incs/Core/System
-I./../SrcShared/Palm/Platform/Incs/Core/UI
-I./../SrcShared/Palm/Platform/Incs/Libraries -I./../SrcShared/Gzip
-I./../SrcShared/jpeg -I./../SrcShared/omnithread -I./../SrcShared/UAE
-I./../SrcUnix -I./../SrcUnix/espws-2.0    -DUNIX -D__PALMOS_TRAPS__=0
-DEMULATION_LEVEL=EMULATION_UNIX -O2  -DHAS_PROFILING=0 -DNDEBUG 
-fexceptions -Wall -Wno-multichar -Wno-unknown-pragmas -Wno-conversion   
-D_REENTRANT -DNoNanoSleep -DPthreadDraftVersion=10 -I/usr/X11R6/include -c
./../SrcShared/MetaMemory.cpp
../SrcShared/UAE/newcpu.h: In function `void
MetaMemory::GWH_ExamineChunk (const EmPalmChunk &,
MetaMemory::WhatHappenedData &)':
../SrcShared/UAE/newcpu.h:225: Internal compiler error in
fix_lexical_addr, at function.c:5320
Please submit a full bug report.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Comment 1 Randy Cushman 2000-11-03 09:17:25 EST
I found a workaround (at least for this module): I replaced 'STATIC_INLINE' with
'static' in ../SrcShared/UAE/newcpu.h:224.
Comment 2 Jakub Jelinek 2000-11-03 10:39:01 EST
Please rerun the above command (with the unmodified source, so that it triggers
the ICE) with -save-temps -v options in addition to those given above and
attach here the resulting .ii output.
Comment 3 Randy Cushman 2000-11-05 11:47:33 EST
Created attachment 5043 [details]
compiler output
Comment 4 Randy Cushman 2000-11-05 11:50:18 EST
Attached please find MetaMemory.ii.
Comment 5 Jakub Jelinek 2000-11-17 06:20:55 EST
This is fixed since gcc-c++-2.96-61 (current rawhide version is -63 I think).

Note You need to log in before you can comment on or make changes to this bug.