Bug 202853 - (wfut) Review Request: wfut - WorldForge media updater tool
Review Request: wfut - WorldForge media updater tool
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Stone
Fedora Package Reviews List
:
Depends On:
Blocks: FE-ACCEPT sear
  Show dependency treegraph
 
Reported: 2006-08-16 15:40 EDT by Wart
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-04 00:16:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wart 2006-08-16 15:40:22 EDT
Spec URL: http://www.kobold.org/~wart/fedora/wfut.spec
SRPM URL: http://www.kobold.org/~wart/fedora/wfut-1.0-1.src.rpm
Description: 
Media updater tool for WorldForge applications
Comment 1 Wart 2006-08-16 18:11:28 EDT
This one loses the "BR: autoconf automake" as they aren't needed anymore:

http://www.kobold.org/~wart/fedora/wfut.spec
http://www.kobold.org/~wart/fedora/wfut-1.0-2.src.rpm
Comment 2 Wart 2006-08-17 16:51:02 EDT
Added a .desktop file and icon, and removed the unnecessary shell script in
/usr/bin:

http://www.kobold.org/~wart/fedora/wfut.spec
http://www.kobold.org/~wart/fedora/wfut-1.0-3.src.rpm
Comment 3 Christopher Stone 2006-09-03 21:27:38 EDT
- rpmlint output clean
- package named according to package naming guildelines
- spec file name matches %{name}
- package meets packaging guidelines
- licensed with open source compatible license
- license matches actual license
- license file included in %doc
- spec file written in American english
- spec file is legible
- sources match upstream
23d40558c121d5c52917846a36d48b80  WFUT-1.0-SNAPSHOT-src.tar.gz
- compiles and builds on fc5 x86_64
- all build dependencies listed in build requires
- package does not use locales
- package does not contain shared libraries
- package is not relocatable
- package owns all directories it creates
- no duplicates in %files
- permissions on files set properly
- contains proper %clean section
- macro usage is consistent
- package contains permissible content
- no large documentation
- %doc files do not affect runtime
- no header files or static libraries
- no pkgconfig files
- no library files
- no devel package
- no .la files
- package is a GUI application and contains proper desktop files
- package does not own files or directories owned by other packages


I can't find anything wrong with this spec file.  Approved.
Comment 4 Wart 2006-09-04 00:16:25 EDT
Imported and built.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.