Bug 202866 - info command does not find grep's info file
info command does not find grep's info file
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: texinfo (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miloslav Trmač
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-08-16 16:42 EDT by Paul Dickson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-08-29 17:59:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/usr/share/info/dir (76.33 KB, text/plain)
2006-08-18 08:40 EDT, Paul Dickson
no flags Details

  None (edit)
Description Paul Dickson 2006-08-16 16:42:25 EDT
Description of problem:
When I type "info grep", I get the info for grepjar

Version-Release number of selected component (if applicable):
grep-2.5.1-54.1

How reproducible:
Always

Steps to Reproduce:
1. Type "info grep"
2.
3.
  
Actual results:
The info for grepjar is displayed from fastjar.info

Expected results:
The info from grep.info

Additional info:
Comment 1 Tim Waugh 2006-08-17 05:04:53 EDT
I don't see this here, so I expect it's to do with which order grep and libgcj
are installed.

mitr: any better idea?
Comment 2 Miloslav Trmač 2006-08-17 09:28:09 EDT
Not really.  Paul, can you please attach your /usr/share/info/dir and, if you
still have it, /root/install.log ?
Comment 3 Paul Dickson 2006-08-18 08:40:03 EDT
Created attachment 134440 [details]
/usr/share/info/dir

My /root/install.log is 16 months old (April 2005), FC4-test2.	Do you still
want this?  /usr/share/info/dir is attached.
Comment 4 Tim Waugh 2006-08-18 09:02:39 EDT
Seems like /sbin/install-info (which gets run during grep's %postinstall
scriptlet) failed for some reason.  Does /usr/share/info/grep.info.gz exist?
Comment 5 Paul Dickson 2006-08-18 12:38:20 EDT
$ ll /usr/share/info/grep.info.gz
-rw-r--r-- 1 root root 25983 Jul 12 06:36 /usr/share/info/grep.info.gz
Comment 6 Paul Dickson 2006-08-18 12:41:16 EDT
Should I try reinstalling grep with rpm?
Comment 7 Tim Waugh 2006-08-18 12:50:40 EDT
Definitely looks like a problem with install-info then.

Paul: what happens when you run this command as root?:

/sbin/install-info --info-dir=/usr/share/info /usr/share/info/grep.info.gz

(this is the command that gets run when grep is installed)
Comment 8 Paul Dickson 2006-08-18 14:08:28 EDT
# /sbin/install-info --info-dir=/usr/share/info /usr/share/info/grep.info.gz
# info grep

No errors and the "info grep" now finds the info file.

Could an incomplete yum update have cause this?  The last grep update seems to
have occurred when yum wasn't logging its activity (June 29 - July 14), but then
yum doesn't appear to log error messages that might have occurred either.
Comment 9 Miloslav Trmač 2006-08-29 13:22:24 EDT
Thanks.

This seems to confirm both install-info and grep.info.gz are correct.  Both
info and grep were rebuild during the June 29..July 14 time, but there were
no code changes at all.

I'm afraid I can't think of a way to determine how this could have happened,
my best guess is an rpm database corruption (incorrect package install
counts) causing grep's %preun scriptlet to remove the entry from
/usr/share/info/dir.

Can you run (rpm --rebuilddb) and paste the output of (rpm -q info grep),
please?

Please also try reinstalling the grep package and check whether the info/dir
entry was removed;
try both (grep -Uvh --replacepkgs grep-VERSION.rpm)
and (rpm -ev grep && rpm -Uvh grep-VERSION.rpm).
Comment 10 Paul Dickson 2006-08-29 14:53:42 EDT
# rpm --rebuilddb
# rpm -q info grep
info-4.8-11.1
grep-2.5.1-54.1
# rpm -Uvh --replacepkgs
/var/cache/yum/development/packages/grep-2.5.1-54.1.i386.rpm 
Preparing...                ########################################### [100%]
   1:grep                   ########################################### [100%]
# info grep
# rpm -ev grep --nodeps && rpm -Uvh
/var/cache/yum/development/packages/grep-2.5.1-54.1.i386.rpm 
Preparing...                ########################################### [100%]
   1:grep                   ########################################### [100%]
# rpm -q grep
grep-2.5.1-54.1
# info grep
# 

The "info grep" worked in both cases.
Comment 11 Miloslav Trmač 2006-08-29 17:59:23 EDT
Thanks for the quick answer.

I really have no idea how this could have happened, and unless there are other
reports of this issue, or you can reproduce it, the best I can do is to assume
this was caused by some random rawhide breakage.

Please reopen this report if you have any additional information.

Note You need to log in before you can comment on or make changes to this bug.