Bug 202878 - wnck-applet going berserk when using amsn
Summary: wnck-applet going berserk when using amsn
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel   
(Show other bugs)
Version: 5
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC5Update
TreeView+ depends on / blocked
 
Reported: 2006-08-16 21:28 UTC by Armijn Hemel
Modified: 2008-03-18 18:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-18 18:33:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Armijn Hemel 2006-08-16 21:28:16 UTC
Description of problem:

Now, this one is a bit weird. Sometimes when using amsn (amsn.sf.net) and
opening a new chat window, the focus will change very rapidly between the main
amsn window
and the chat window. The wnck-applet (if that is the window list applet) will
go completely berserk, sending load of the machine easily through the roof in
no-time. The only option is to either kill X, or to go to a console and kill
amsn, wnck-applet and metacity. Now, I suspect this to be more a bug in amsn (or
in wish, it is tcl based), but I'm surprised an application can actually trigger
this in wnck-applet/metacity.

Version-Release number of selected component (if applicable):

gnome-panel-2.14.3

How reproducible:
Random

Steps to Reproduce:
1. install amsn
2. open chat windows
3. wait until stuff goes wrong.
  
Actual results:
load goes through the roof

Expected results:
nothing

Additional info:
I've seen this on multiple machines for quite a while (FC3, FC5, various amsn
versions) and it bugs me. I actually don't know *where* to find the bug. As I
said, it is very possible this is in wish or amsn, but I'm not sure.

Comment 1 Ray Strode [halfline] 2006-08-16 22:29:11 UTC
So I'm pretty sure some cycle detection code went into libwnck post-fc5.  Do you
have a rawhide box? if so can you confirm it fixed there?  If it is, we can
probably backport the fix and push an update.

If you don't have a rawhide box, i can try to dig up the code anyway and you can
test it.

Comment 2 Armijn Hemel 2006-08-16 22:51:14 UTC
Yes, I do have one in vmware and one normal one. I will do some testing soon
(next week) with them.

Comment 3 Armijn Hemel 2006-12-17 14:59:20 UTC
I tested with FC6. While the problem is a lot less frequent, it sometimes pops
up again.

Comment 4 Ray Strode [halfline] 2008-03-18 18:33:25 UTC
Hi,

We no longer support Fedora Core 5 and I am currently trying to get my open bug
count down to a more manageable state.  I'm going to close this bug as WONTFIX.
 If this issue is still a concern for you, would you mind trying to reproduce on
a supported version of Fedora and reopening?

(this is a mass message)


Note You need to log in before you can comment on or make changes to this bug.